Context Class

This .NET class wraps the OdGiContext class that defines common operations and properties that are used in the ODA Platform vectorization process. Most of the virtual functions and properties in this class are no-ops, serving only to define an interface.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceContext
          Teigha.GraphicsInterfaceContextForDbDatabase

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class Context : RXObject

The Context type exposes the following members.

Constructors
  Name Description
Protected method Context Initializes a new instance of the Context class
Protected method Context(IntPtr, Boolean) Initializes a new instance of the Context class
Top
Properties
  Name Description
Public property ByBlockLineWeight  
Public property ByBlockPlotStyleNameId  
Public property Database Property that represents a database that is currently being vectorized.
Public property EffectiveColor  
Public property IsBoundaryClipping Property that represents a flag that indicates whether boundary clipping is currently active.
Public property IsNesting  
Public property IsPlotGeneration Property that represents a flag that indicates whether regen is used for hard copy output.
Public property IsPostScriptOut Property that represents a flag that indicates whether regen is used for PostScript output.
Public property SupportsTrueTypeText  
Top
Methods
  Name Description
Public method DisableFastMoveDrag  
Top
See Also

©  Bricsys NV. All rights reserved.