ContextForDbDatabase Class

This defines the operations and properties that are used for the vectorization of database objects.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceContext
          Teigha.GraphicsInterfaceContextForDbDatabase

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class ContextForDbDatabase : Context

The ContextForDbDatabase type exposes the following members.

Constructors
  Name Description
Public method ContextForDbDatabase Constructor for the ContextForDbDatabase class. Creates a context with a database to vectorize.
Top
Properties
  Name Description
Public property Database Property that represents a database that is currently being vectorized.
(Overrides ContextDatabase)
Public property EnableConstantModelSpaceLineweights  
Public property IsBoundaryClipping Property that represents a flag that indicates whether boundary clipping is currently active.
(Overrides ContextIsBoundaryClipping)
Public property IsPlotGeneration Property that represents a flag that indicates whether plot generation is enabled.
(Overrides ContextIsPlotGeneration)
Public property IsPostScriptOut Property that represents a flag that indicates whether regen is used for PostScript output.
(Overrides ContextIsPostScriptOut)
Public property PaletteBackground Property that represents a palette background color.
Public property UseGsModel  
Top
Methods
  Name Description
Public method LoadPlotStyleTable Loads the specified plot style table for this context object.
Public method SetPlotGeneration Controls the plot generation option.
Top
See Also

©  Bricsys NV. All rights reserved.