Clip
|
The ClipBoundary2d type exposes the following members.
Name | Description | |
---|---|---|
![]() |
ClipBoundary2d | Default constructor for the ClipBoundary2d class. Creates a clipping boundary with no actual data assigned. |
![]() |
ClipBoundary2d(Point2dCollection) | Constructor for the ClipBoundary2d class. Creates a clipping boundary from the given points. |
![]() |
ClipBoundary2d(Point2d, Point2d) | Constructor for the ClipBoundary2d class. Creates a rectangular clipping boundary from the given two corner points. |
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
Name | Description | |
---|---|---|
![]() |
ClipPolygon | Clips a polygon formed by the passed points. |
![]() |
ClipPolyline | Clips a polyline formed by the passed points. |
![]() |
Clone | Clones this entity and returns a handle to the cloned
entity. (Inherited from Entity2d) |
![]() ![]() |
Create | Creates a CircularArc2d object based on the passed pointer. |
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
Equals | (Inherited from DisposableWrapper) |
![]() |
GetHashCode | (Inherited from DisposableWrapper) |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
IsEqualTo(Entity2d) | Checks whether this entity is equal to the specified
entity. (Inherited from Entity2d) |
![]() |
IsEqualTo(Entity2d, Tolerance) | Checks whether this entity is equal to the specified entity
within a geometric tolerance. (Inherited from Entity2d) |
![]() |
IsOn(Point2d) | Checks whether the specified point is on this entity. (Inherited from Entity2d) |
![]() |
IsOn(Point2d, Tolerance) | Checks whether the specified point is on this entity according
to a geometric tolerance. (Inherited from Entity2d) |
![]() |
Mirror | Mirrors this entity about the specified 2D line. (Inherited from Entity2d) |
![]() |
RotateBy | Rotates this entity about the specified point by the specified
angle. (Inherited from Entity2d) |
![]() |
ScaleBy | Scales this entity by the specified scale factor about the
specified point. (Inherited from Entity2d) |
![]() |
Set(Point2dCollection) | Sets the clip boundary with the specified points. |
![]() |
Set(Point2d, Point2d) | Resets the object to a rectangular clipping boundary. |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
![]() |
TransformBy | Applies the specified 2D transformation matrix to this
entity. (Inherited from Entity2d) |
![]() |
TranslateBy | Translates this entity by applying a 2D translation
vector. (Inherited from Entity2d) |
© Bricsys NV. All rights reserved. |