Memory
|
The MemoryStreamBuf type exposes the following members.
Name | Description | |
---|---|---|
![]() |
MemoryStreamBuf | Default constructor for the MemoryStreamBuf class. |
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
![]() |
FileName | This property represents name of the file associated with this
StreamBuf object. (Inherited from StreamBuf) |
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
![]() |
IsEof | This property indicates whether current position of the file
pointer for this stream buffer is at the end of file. (Overrides StreamBufIsEof) |
![]() |
Length | This property represents the length in bytes of the file
associated with this stream buffer. (Overrides StreamBufLength) |
![]() |
ShareMode | This property represents the share mode for this StreamBuf
object. It can be: ValueDescription0x10 deny
read/write mode 0x20 deny write mode 0x30 deny read mode 0x40 deny
none mode (Inherited from StreamBuf) |
![]() |
Tell | This property represents the current position of the file
pointer for this stream buffer. (Overrides StreamBufTell) |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
Name | Description | |
---|---|---|
![]() |
Clone | (Inherited from RXObject) |
![]() |
CompareTo | (Inherited from RXObject) |
![]() |
CopyFrom | (Inherited from RXObject) |
![]() |
CopyTo(StreamBuf) | Copies bytes from this StreamBuf object to the specified
StreamBuf object. (Inherited from StreamBuf) |
![]() |
CopyTo(StreamBuf, UInt64) | Copies bytes from this StreamBuf object to the specified
StreamBuf object. (Inherited from StreamBuf) |
![]() |
CopyTo(StreamBuf, UInt64, UInt64) | Copies bytes from this stream buffer to the specified stream
buffer. (Overrides StreamBufCopyTo(StreamBuf, UInt64, UInt64)) |
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
DeleteUnmanagedObject | (Inherited from RXObject) |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper) |
![]() |
Equals | (Inherited from DisposableWrapper) |
![]() |
Finalize | (Inherited from DisposableWrapper) |
![]() |
GetHashCode | (Inherited from DisposableWrapper) |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetMetaObject | (Inherited from RXObject) |
![]() |
GetRXClass | (Inherited from RXObject) |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object) |
![]() |
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject) |
![]() |
QueryX | (Inherited from RXObject) |
![]() |
Read | Reads a byte at current position of a file pointer. (Overrides StreamBufRead) |
![]() |
Read(UInt32) | Reads the specified number of bytes at current position of a
file pointer. (Overrides StreamBufRead(UInt32)) |
![]() |
Rewind | Sets the current position of the file pointer for this stream
buffer to zero. (Overrides StreamBufRewind) |
![]() |
Seek | Moves the current position of the file pointer for this stream
buffer to the specified location. (Overrides StreamBufSeek(Int64, FilerSeekType)) |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
![]() |
Truncate | Sets the length of the file associated with this stream buffer
to zero. (Overrides StreamBufTruncate) |
![]() |
Write(Byte) | Writes the byte to the current position of the file pointer for
this stream buffer, and increments the pointer. (Overrides StreamBufWrite(Byte)) |
![]() |
Write(Byte, UInt32) | Writes the specified amount of bytes to the current position of
the file pointer for this stream buffer, and increments the pointer
by the specified amount. (Overrides StreamBufWrite(Byte, UInt32)) |
![]() |
X | (Inherited from RXObject) |
© Bricsys NV. All rights reserved. |