IFCImportReactor Class |
The IFCImportReactor type exposes the following members.
Name | Description | |
---|---|---|
![]() |
IFCImportReactor |
Initializes a new instance of the IFCImportReactor class
|
Name | Description | |
---|---|---|
![]() |
AngleConversionFactor | |
![]() |
AreaConversionFactor | |
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
Ifc2x3Enabled | |
![]() |
Ifc4Enabled | |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
LengthConversionFactor | |
![]() |
Precision | |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
![]() |
VolumeConversionFactor |
Name | Description | |
---|---|---|
![]() |
AttachReactor | |
![]() |
BeforeCompletion | |
![]() |
CreateDefaultRepresentation | |
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
CreatePoint | |
![]() |
CreateRepresentationFromItem | |
![]() |
CreateSweptArea | |
![]() |
DeleteUnmanagedObject | (Overrides DisposableWrapperDeleteUnmanagedObject.) |
![]() |
DetachReactor | |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
Finalize | (Inherited from DisposableWrapper.) |
![]() |
GetDatabase | |
![]() |
GetEntity(Entity, IfcEntity) | |
![]() |
GetEntity(ObjectId, IfcEntity) | |
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetIfcModel | |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetLocalPlacement | |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() ![]() |
IsFullySupported | |
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
MemberwiseClone(Boolean) |
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.) |
![]() |
OnIfcProduct | |
![]() |
OnStart | |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
© Bricsys NV. All rights reserved. |