BIMProfile Class

Inheritance Hierarchy
Namespace:  Bricscad.Bim
Assembly:  BrxMgd (in BrxMgd.dll) Version: 21.0.0.15598
Syntax
public class BIMProfile : DisposableWrapper

The BIMProfile type exposes the following members.

Constructors
  Name Description
Public method BIMProfile
Initializes a new instance of the BIMProfile class
Public method BIMProfile(BIMProfile)
Initializes a new instance of the BIMProfile class
Public method BIMProfile(ObjectId)
Initializes a new instance of the BIMProfile class
Top
Properties
  Name Description
Public property GetDescription
Public property GetName
Public property GetShape
Public property GetStandard
Top
Methods
  Name Description
Public methodStatic member AddProfileFromXML
Public method ApplyProfileTo(ObjectId, Double, Boolean)
Public methodStatic member ApplyProfileTo(BIMProfile, ObjectId, Double, Boolean)
Protected method DeleteUnmanagedObject (Overrides DisposableWrapperDeleteUnmanagedObject.)
Public methodStatic member GetAllAssignedObjects
Public methodStatic member GetAllLibraryProfiles
Public methodStatic member GetAllProfileNames
Public methodStatic member GetAllProfiles
Public methodStatic member GetAllProfileSizes
Public methodStatic member GetAllProfileStandards
Public methodStatic member GetAssignedProfile
Public methodStatic member GetDescriptionProfile
Public methodStatic member GetNameProfile
Public methodStatic member GetProfile
Public method GetProfileCurves
Public method GetProfileCurves(Database)
Public methodStatic member GetShapeProfile
Public methodStatic member GetStandardProfile
Public method IsValid
Public methodStatic member IsValid(BIMProfile)
Public methodStatic member RemoveProfileFrom
Public method SaveProfile(Database)
Public methodStatic member SaveProfile(BIMProfile, Database)
Public method SetFromId
Top
See Also

©  Bricsys NV. All rights reserved.