BIMRoom Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Bricscad.BimBIMObject
        Bricscad.BimBIMRoom

Namespace: Bricscad.Bim
Assembly: BrxMgd (in BrxMgd.dll) Version: 24.0.1.0
Syntax
public class BIMRoom : BIMObject

The BIMRoom type exposes the following members.

Constructors
  Name Description
Public method BIMRoom Initializes a new instance of the BIMRoom class
Public method BIMRoom(BIMRoom) Initializes a new instance of the BIMRoom class
Public method BIMRoom(ObjectId) Initializes a new instance of the BIMRoom class
Top
Properties
  Name Description
Public property Name
(Overrides BIMObjectName)
Public property ObjId  
Public property RoomArea  
Public property RoomDepartment  
Public property RoomIdent  
Public property RoomName  
Public property RoomNumber  
Public property RoomRepresentation  
Top
Methods
  Name Description
Public method AssignToBuilding(BIMBuilding)  
Public methodStatic member AssignToBuilding(ObjectId, BIMBuilding)  
Public method AssignToStory(BIMStory)  
Public methodStatic member AssignToStory(ObjectId, BIMStory)  
Public methodStatic member BuildNonAssociativeRoom  
Public method CreateAssociativeRoom  
Public method CreateNonAssociativeRoom  
Public methodStatic member GetAllRooms(Database)  
Public methodStatic member GetAllRooms(BIMBuilding, Database)  
Public methodStatic member GetAllRooms(BIMStory, Database)  
Public method GetAssignedBuilding  
Public method GetAssignedLocation  
Public method GetAssignedStory  
Public method GetBoundingElements  
Public method GetOpenings  
Public methodStatic member GetRoomArea  
Public methodStatic member GetRoomDepartment  
Public methodStatic member GetRoomDescription  
Public methodStatic member GetRoomIdent  
Public methodStatic member GetRoomName  
Public methodStatic member GetRoomNumber  
Public methodStatic member GetRoomRepresentation  
Public method IsAssociativeRoom  
Public methodStatic member IsAssociativeRoom(ObjectId)  
Public methodStatic member SetRoomDepartment  
Public methodStatic member SetRoomDescription  
Public methodStatic member SetRoomName  
Public methodStatic member SetRoomNumber  
Public methodStatic member SetRoomRepresentation  
Public method SetToNull
(Overrides BIMObjectSetToNull)
Public method UnassignLocation  
Public methodStatic member UnassignLocation(ObjectId)  
Public method UpdateAssociativeRoom  
Top
Operators
See Also

©  Bricsys NV. All rights reserved.