Converter Class

This class provides methods to convert between string values, numeric angles and distance values. This class is able to use unit formats and precision.
Inheritance Hierarchy
SystemObject
  Teigha.RuntimeConverter

Namespace: Teigha.Runtime
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class Converter

The Converter type exposes the following members.

Constructors
  Name Description
Public method Converter Initializes a new instance of the Converter class
Top
Methods
  Name Description
Public methodStatic member AngleToString(Double) Converts the specified angle to a string and returns the resulting string. This method uses default AngularUnitFormat::Current format and 0 conversion precision (number of digits to preserve after the floating point).
Public methodStatic member AngleToString(Double, AngularUnitFormat, Int32) Converts the specified angle to a string according to the specified units format and precision and returns the resulting string.
Public methodStatic member DistanceToString(Double) Converts the specified distance to a string and returns the resulting string. This method uses default DistanceUnitFormat::Current format and 0 conversion precision (number of digits to preserve after the floating point).
Public methodStatic member DistanceToString(Double, DistanceUnitFormat, Int32) Converts the specified distance to a string according to the specified units format and precision and returns the resulting string.
Public methodStatic member RawAngleToString(Double) Converts the specified raw angle to a string and returns the resulting string. Currently not implemented.
Public methodStatic member RawAngleToString(Double, AngularUnitFormat, Int32) Converts the specified raw angle to a string according to the specified units format and precision and returns the resulting string. Currently not implemented.
Public methodStatic member StringToAngle(String) Converts the specified string to an angle according to the current angular units format. Currently not implemented.
Public methodStatic member StringToAngle(String, AngularUnitFormat) Converts the specified string to an angle according to the specified angular units format. Currently not implemented.
Public methodStatic member StringToDistance(String) Converts the specified string to a distance value according to the current distance units format.
Public methodStatic member StringToDistance(String, DistanceUnitFormat) Converts the specified string to a distance value according to the specified distance units format.
Public methodStatic member StringToRawAngle(String) Converts the specified string to a raw angle according to the current angular units format. Currently not implemented.
Public methodStatic member StringToRawAngle(String, AngularUnitFormat) Converts the specified string to a raw angle according to the specified angular units format. Currently not implemented.
Top
See Also

©  Bricsys NV. All rights reserved.