MemberComponent Class

This class represents structural member components. The components can be used to create a complex structural member.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.Aec.DatabaseServicesImpObject
          Teigha.Aec.Structural.DatabaseServicesMemberComponent

Namespace: Teigha.Aec.Structural.DatabaseServices
Assembly: TA_MgdStructure (in TA_MgdStructure.dll) Version: 0.0.0.0
Syntax
public class MemberComponent : ImpObject

The MemberComponent type exposes the following members.

Constructors
  Name Description
Public method MemberComponent Default constructor for the MemberComponent class.
Protected method MemberComponent(IntPtr, Boolean) Initializes a new instance of the MemberComponent class
Top
Properties
  Name Description
Public property EndNode Property that represents the end node component of the structural member component. You can assign shapes to nodes and make a transition between shapes of different nodes along the member component's path.
Public property EndOffset Property that represents the offset from the end point of the path.
Public property MaterialId Property that represents an identifier of the material applied to the component.
Public property Name Property that represents the name of the component.
Public property Priority Property that represents the priority of the component. Components that start and end at a common node are mitered based on their priorities. Components with the same priority are factored into the miter angle between the components. Components with different priorities are not factored into the miter angle.
Public property StartNode Property that represents the start node component of the structural member component. You can assign shapes to nodes and make a transition between shapes of different nodes along the member component's path.
Public property StartOffset Property that represents the offset from the start point of the path.
Top
Methods
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.