Object
|
The ObjectContextCollection type exposes the following members.
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
![]() |
CurrentContext | Property that represents the current context of the context collection. |
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
![]() |
Name | |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
Name | Description | |
---|---|---|
![]() |
AddContext | Copies a context and adds the copy to the context collection. The new context is assigned a new unique identifier. |
![]() |
Clone | (Inherited from RXObject) |
![]() |
CompareTo | (Inherited from RXObject) |
![]() |
CopyFrom | (Inherited from RXObject) |
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
DeleteUnmanagedObject | (Inherited from RXObject) |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper) |
![]() |
Equals | (Inherited from DisposableWrapper) |
![]() |
Finalize | (Inherited from DisposableWrapper) |
![]() |
GetContext | Returns a copy of a named context in the collection. |
![]() |
GetEnumerator | Returns an enumerator for this object. |
![]() |
GetHashCode | (Inherited from DisposableWrapper) |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetRXClass | (Inherited from RXObject) |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
HasContext | Checks whether a named context exists in the collection. |
![]() |
IEnumerable_GetEnumerator | Returns an enumerator for this object. |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object) |
![]() |
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject
object. (Inherited from MarshalByRefObject) |
![]() |
QueryX | (Inherited from RXObject) |
![]() |
RemoveContext | Removes a context from the context collection. |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
![]() |
X | (Inherited from RXObject) |
© Bricsys NV. All rights reserved. |