BoundBlock2d Class

This .NET class wraps the OdGeBoundBlock2d class.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity2d
        Teigha.GeometryBoundBlock2d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class BoundBlock2d : Entity2d

The BoundBlock2d type exposes the following members.

Constructors
  Name Description
Public method BoundBlock2d Default constructor for the BoundBlock2d class. Constructs a bounding block with minimum and maximum points at the coordinate system origin.
Public method BoundBlock2d(IntPtr) Initializes a new instance of the BoundBlock2d class
Public method BoundBlock2d(Point2d, Point2d) Constructor for the BoundBlock2d class. Constructs a bounding block with specified minimum and maximum points.
Public method BoundBlock2d(Point2d, Vector2d, Vector2d) Constructor for the BoundBlock2d class. Constructs a bounding block with specified base point.
Top
Properties
  Name Description
Public property BasePoint  
Public property Direction1  
Public property Direction2  
Public property IsBox  
Top
Methods
  Name Description
Public method Contains Checks if this bounding block contains the specified point.
Public methodStatic member Create Creates a BoundBlock2d object based on the passed pointer.
Public method Extend Extends the bounding block to contain the specified point.
Public method GetMaximumPoint Retrieves the maximum point of this bounding block.
Public method GetMinimumPoint Retrieves the minimum point of this bounding block.
Public method IsDisjoint Checks if this bounding block does not intersect with the specified bounding block.
Public method Set(Point2d, Point2d) Sets the minimum and maximum points of the bounding block.
Public method Set(Point2d, Vector2d, Vector2d) Sets the base point and sides of the parallelogram bounding block.
Public method Swell Moves the walls of this bounding block by the specified distance.
Top
See Also

©  Bricsys NV. All rights reserved.