Abstract
|
The AbstractViewPE type exposes the following members.
Name | Description | |
---|---|---|
![]() |
AbstractViewPE | Constructor for the AbstractViewPE class. Creates an object from the specified viewport. |
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
![]() |
BackClipDistance | |
![]() |
Direction | |
![]() |
Elevation | |
![]() |
EyeToWorld | |
![]() |
FieldHeight | |
![]() |
FieldWidth | |
![]() |
FrontClipDistance | |
![]() |
FrozenLayers | |
![]() |
HasUcs | |
![]() |
HasViewOffset | |
![]() |
HasViewport | |
![]() |
IsBackClipOn | |
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
![]() |
IsFrontClipAtEyeOn | |
![]() |
IsFrontClipOn | |
![]() |
IsPerspective | |
![]() |
IsPlotting | |
![]() |
LensLength | |
![]() |
LowerLeftCorner | |
![]() |
OrthoUcs | |
![]() |
RenderMode | |
![]() |
Target | |
![]() |
Ucs | |
![]() |
UcsName | |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
![]() |
UpperRightCorner | |
![]() |
UpVector | |
![]() |
ViewOffset | |
![]() |
ViewTwist | |
![]() |
VisualStyle | |
![]() |
WorldToEye |
Name | Description | |
---|---|---|
![]() |
Clone | (Inherited from RXObject) |
![]() |
CompareTo | (Inherited from RXObject) |
![]() |
CopyFrom | (Inherited from RXObject) |
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
DeleteUnmanagedObject | (Inherited from RXObject) |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper) |
![]() |
Equals | (Inherited from DisposableWrapper) |
![]() |
Finalize | (Inherited from DisposableWrapper) |
![]() ![]() |
GetClass | Retrieves the class associated with this protocol extension. |
![]() |
GetHashCode | (Inherited from DisposableWrapper) |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetPlotExtents | Returns the eye coordinate system plot extents of the associated viewport. |
![]() |
GetRXClass | (Inherited from RXObject) |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
GetViewExtents | Returns the eye coordinate system extents of the associated viewport. |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object) |
![]() |
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject
object. (Inherited from MarshalByRefObject) |
![]() |
QueryX | (Inherited from RXObject) |
![]() |
SetUcsFromView | Sets the UCS for the associated viewport. |
![]() |
SetView(RXObject) | Sets view parameters from the specified view. |
![]() |
SetView(Point3d, Vector3d, Vector3d, Double, Double, Boolean, Vector2d) | Sets the parameters for the specified Viewport object according to the arguments. |
![]() |
SetViewport | Sets the corners of the specified Viewport object. |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
![]() |
X | (Inherited from RXObject) |
![]() |
ZoomExtents | Modifies an associated Viewport object to fit the specified eye coordinate system extents. |
![]() |
ZoomExtents(BoundBlock3d) | Modifies an associated Viewport object to fit the specified eye coordinate system extents. |
![]() |
ZoomExtents(BoundBlock3d, Double) | Modifies an associated Viewport object to fit the specified eye coordinate system extents. |
© Bricsys NV. All rights reserved. |