AbstractViewportData Class

This class is the base class of Protocol Extension classes for Viewport and ViewportTableRecord objects.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesAbstractViewPE
          Teigha.DatabaseServicesAbstractViewportData

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class AbstractViewportData : AbstractViewPE

The AbstractViewportData type exposes the following members.

Constructors
  Name Description
Public method AbstractViewportData Constructor for the AbstractViewportData class. Creates an object from the specified viewport.
Top
Properties
  Name Description
Public property CircleSides  
Public property GridIncrement  
Public property GsView Property that represents an associated view.
Public property IsGridOn  
Public property IsSnapIsometric  
Public property IsSnapOn  
Public property IsUcsFollowModeOn  
Public property IsUcsIconAtOrigin  
Public property IsUcsIconVisible  
Public property IsUcsSavedWithViewport  
Public property SnapAngle  
Public property SnapBase  
Public property SnapIncrement  
Public property SnapIsoPair  
Top
Methods
  Name Description
Public methodStatic member GetClass Retrieves the class associated with this abstract viewport data.
Public method SetProps Sets the parameters of the associated viewport object from the source view.
Top
See Also

©  Bricsys NV. All rights reserved.