PointOnSurface Class

Inheritance Hierarchy
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public sealed class PointOnSurface : PointEntity3d

The PointOnSurface type exposes the following members.

Constructors
  Name Description
Public method PointOnSurface
Initializes a new instance of the PointOnSurface class
Public method PointOnSurface(Surface, Point2d)
Initializes a new instance of the PointOnSurface class
Top
Properties
  Name Description
Public property Parameter
Public property Surface
Top
Methods
  Name Description
Public methodStatic member Create
Public method GetInverseTangentVector(Vector3d)
Public method GetInverseTangentVector(Vector3d, Point2d)
Public methodStatic member GetInverseTangentVector(Vector3d, Surface, Point2d)
Public method GetMixedPartial
Public method GetMixedPartial(Point2d)
Public methodStatic member GetMixedPartial(Surface, Point2d)
Public method GetNormal
Public method GetNormal(Point2d)
Public methodStatic member GetNormal(Surface, Point2d)
Public method GetPoint(Point2d)
Public methodStatic member GetPoint(Surface, Point2d)
Public method GetTangentVector(Vector2d)
Public method GetTangentVector(Vector2d, Point2d)
Public methodStatic member GetTangentVector(Vector2d, Surface, Point2d)
Public method GetUDerivative(Int32)
Public method GetUDerivative(Int32, Point2d)
Public methodStatic member GetUDerivative(Int32, Surface, Point2d)
Public method GetVDerivative(Int32)
Public method GetVDerivative(Int32, Point2d)
Public methodStatic member GetVDerivative(Int32, Surface, Point2d)
Top
See Also

©  Bricsys NV. All rights reserved.