View Class

Inheritance Hierarchy
Namespace:  Teigha.GraphicsSystem
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public class View : RXObject

The View type exposes the following members.

Constructors
  Name Description
Public method View
Initializes a new instance of the View class
Protected method View(IntPtr, Boolean)
Initializes a new instance of the View class
Top
Properties
Methods
  Name Description
Public method Add(Drawable)
Public method Add(Drawable, Model)
Public method BeginInteractivity
Public method ClearFrozenLayers
Public method CloneView
Public method CloneView(Boolean)
Public method CloneView(Boolean, Boolean)
Protected method DeleteUnmanagedObject (Overrides RXObjectDeleteUnmanagedObject.)
Public method Dolly(Vector3d)
Public method Dolly(Double, Double, Double)
Public method EnableDefaultLighting(Boolean)
Public method EnableDefaultLighting(Boolean, DefaultLightingType)
Public method EndInteractivity
Public method Erase
Public method EraseAll
Public method ExtentsInView
Public method Flush
Public method FreezeLayer
Public method GetModel
Public method GetModelList
Public method GetNumPixelsInUnitSquare(Point3d)
Public method GetNumPixelsInUnitSquare(Point3d, Boolean)
Public method GetSnapshot
Public method Hide
Public method InitLights
Public method Invalidate
Public method Invalidate(Rectangle)
Public method InvalidateCachedViewportGeometry
Public method Orbit
Public method Pan
Public method PointInView
Public method PointInViewport
Public method RemoveViewportClipRegion
Public method Roll
Public method Select
Public method SetLineweights
Public method SetView(Point3d, Point3d, Vector3d, Double, Double)
Public method SetView(Point3d, Point3d, Vector3d, Double, Double, Projection)
Public method Show
Public method ThawLayer
Public method Update
Public method ViewParameters
Public method Zoom
Public method ZoomExtents
Public method ZoomWindow
Top
See Also

©  Bricsys NV. All rights reserved.