ExternalSurface Class |
The ExternalSurface type exposes the following members.
Name | Description | |
---|---|---|
![]() |
ExternalSurface |
Initializes a new instance of the ExternalSurface class
|
![]() |
ExternalSurface(IntPtr, ExternalEntityKind) |
Initializes a new instance of the ExternalSurface class
|
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
ExternalSurfaceDefiniton | |
![]() |
ExternalSurfaceKind | |
![]() |
IsCone | |
![]() |
IsCylinder | |
![]() |
IsDefined | |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
IsEllipCone | |
![]() |
IsEllipCylinder | |
![]() |
IsNativeSurface | |
![]() |
IsNormalReversed | (Inherited from Surface.) |
![]() |
IsNurbSurface | |
![]() |
IsOwnerOfSurface | |
![]() |
IsPlane | |
![]() |
IsSphere | |
![]() |
IsTorus | |
![]() |
nativeSurface | |
![]() |
ReverseNormal | (Inherited from Surface.) |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
Name | Description | |
---|---|---|
![]() |
Clone | (Inherited from Entity3d.) |
![]() |
ClosestPointTo(Point3d) | (Inherited from Surface.) |
![]() |
ClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.) |
![]() ![]() |
Create | |
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
DistanceTo(Point3d) | (Inherited from Surface.) |
![]() |
DistanceTo(Point3d, Tolerance) | (Inherited from Surface.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
EvaluatePoint | (Inherited from Surface.) |
![]() |
GetClosestPointTo(Point3d) | (Inherited from Surface.) |
![]() |
GetClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.) |
![]() |
GetEnvelope | (Inherited from Surface.) |
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
IsClosedInU | (Inherited from Surface.) |
![]() |
IsClosedInU(Tolerance) | (Inherited from Surface.) |
![]() |
IsClosedInV | (Inherited from Surface.) |
![]() |
IsClosedInV(Tolerance) | (Inherited from Surface.) |
![]() |
IsEqualTo(Entity3d) | (Inherited from Entity3d.) |
![]() |
IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.) |
![]() |
IsOn(Point3d) | (Inherited from Entity3d.) |
![]() |
IsOn(Point3d, Tolerance) | (Inherited from Entity3d.) |
![]() |
IsOn(Point3d, Point2d) | (Inherited from Surface.) |
![]() |
IsOn(Point3d, Point2d, Tolerance) | (Inherited from Surface.) |
![]() |
Mirror | (Inherited from Entity3d.) |
![]() |
ParameterOf(Point3d) | (Inherited from Surface.) |
![]() |
ParameterOf(Point3d, Tolerance) | (Inherited from Surface.) |
![]() |
RotateBy | (Inherited from Entity3d.) |
![]() |
ScaleBy | (Inherited from Entity3d.) |
![]() |
Set | |
![]() |
SetToOwnSurface | |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
![]() |
TransformBy | (Inherited from Entity3d.) |
![]() |
TranslateBy | (Inherited from Entity3d.) |
© Bricsys NV. All rights reserved. |