Surface Class

Inheritance Hierarchy
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public abstract class Surface : Entity3d

The Surface type exposes the following members.

Properties
  Name Description
Public property IsNormalReversed
Public property ReverseNormal
Top
Methods
  Name Description
Public method ClosestPointTo(Point3d)
Public method ClosestPointTo(Point3d, Tolerance)
Public methodStatic member Create
Public method DistanceTo(Point3d)
Public method DistanceTo(Point3d, Tolerance)
Public method EvaluatePoint
Public method GetClosestPointTo(Point3d)
Public method GetClosestPointTo(Point3d, Tolerance)
Public method GetEnvelope
Public method IsClosedInU
Public method IsClosedInU(Tolerance)
Public method IsClosedInV
Public method IsClosedInV(Tolerance)
Public method IsOn(Point3d, Point2d)
Public method IsOn(Point3d, Point2d, Tolerance)
Public method ParameterOf(Point3d)
Public method ParameterOf(Point3d, Tolerance)
Top
See Also
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        Teigha.GeometrySurface
          Teigha.GeometryCone
          Teigha.GeometryCylinder
          Teigha.GeometryEllipticalCone
          Teigha.GeometryEllipticalCylinder
          Teigha.GeometryExternalBoundedSurface
          Teigha.GeometryExternalSurface
          Teigha.GeometryNurbSurface
          Teigha.GeometryOffsetSurface
          Teigha.GeometryPlanarEntity
          Teigha.GeometrySphere
          Teigha.GeometryTorus

©  Bricsys NV. All rights reserved.