LayoutManager Class

This class modifies and accesses Layout objects in a database.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesLayoutManager

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class LayoutManager : RXObject

The LayoutManager type exposes the following members.

Constructors
  Name Description
Protected method LayoutManager Initializes a new instance of the LayoutManager class
Top
Properties
  Name Description
Public propertyStatic member Current Property that represents the current layout manager.
Public property CurrentLayout Property that represents the current layout.
Public property LayoutCount Property that represents the current number of layouts.
Top
Methods
  Name Description
Public method CloneLayout Clones a layout with a given layout name (copyName), sets the name for the new cloned layout, and specifies the tab order.
Public method CopyLayout Copies a layout with a given layout name (copyName) and sets the name for the new copied layout.
Public method CreateLayout Creates a new Layout object with the specified layout name. The layout name must be unique.
Public method DeleteLayout Deletes a layout with the specified name from the database.
Public method GetLayoutId Returns an object ID of a layout with the specified name.
Public method GetNonRectangularViewportIdFromClipId Returns the object ID for the non-rectangular viewport ID associated with the specified object ID of a clip entity.
Public method RenameLayout Renames the layout that has the name represented by the oldName parameter.
Top
Events
Fields
  Name Description
Public field m_pAbortLayoutCopied Event triggered when the copying of a layout is terminated.
Public field m_pAbortLayoutRemoved Event triggered when the removal of a layout is terminated.
Public field m_pAbortLayoutRename Event triggered when the renaming of a layout is terminated.
Public field m_pLayoutCopied Event triggered when a layout is copied.
Public field m_pLayoutCreated Event triggered when a layout is created and added to a database.
Public field m_pLayoutRemoved Event triggered when a layout is removed from a database.
Public field m_pLayoutRenamed Event triggered when a layout is renamed.
Public field m_pLayoutsReordered Event triggered when the layouts are reordered.
Public field m_pLayoutSwitched Event triggered when the active layout is changed.
Public field m_pLayoutToBeCopied Event triggered when a layout is about to be copied.
Public field m_pLayoutToBeRemoved Event triggered when a layout is about to be removed from a database.
Public field m_pLayoutToBeRenamed Event triggered when a layout is about to be renamed.
Public field m_pPlotStyleTableChanged Event triggered when the plot style table associated with a layout is changed.
Top
See Also

©  Bricsys NV. All rights reserved.