BoundBlock3d Class

This .NET class wraps the OdGeBoundBlock3d class.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        Teigha.GeometryBoundBlock3d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class BoundBlock3d : Entity3d

The BoundBlock3d type exposes the following members.

Constructors
  Name Description
Public method BoundBlock3d Default constructor for the BoundBlock3d class. Constructs a bounding block with minimum and maximum points at the coordinate system origin.
Public method BoundBlock3d(Point3d, Vector3d, Vector3d, Vector3d) Constructor for the BoundBlock3d class. Constructs a bounding block with the specified base point.
Top
Properties
  Name Description
Public property BasePoint  
Public property Direction1  
Public property Direction2  
Public property Direction3  
Public property IsBox  
Top
Methods
  Name Description
Public method center Returns a center point of this Extents object..
Public method Contains Checks whether this bounding block contains the specified point.
Public methodStatic member Create Creates a BoundBlock3d object based on the passed pointer.
Public method Extend Extends the bounding block to contain the specified point.
Public method GetMaximumPoint Retrieves the maximum point of this bounding block.
Public method GetMinimumPoint Retrieves the minimum point of this bounding block.
Public method IsDisjoint Checks if this bounding block does not intersect with the specified bounding block.
Public method Set(Point3d, Point3d) Sets the minimum and maximum points of the bounding block.
Public method Set(Point3d, Vector3d, Vector3d, Vector3d) Sets the base point and sides of a parallelogram bounding block.
Public method Swell Moves the walls of this bounding block by the specified distance.
Public method TransformBy Transforms this bounding block by the specified 3D matrix.
Top
See Also

©  Bricsys NV. All rights reserved.