AcadBlockClass Class

Inheritance Hierarchy
SystemObject
  BricscadDbAcadBlockClass

Namespace: BricscadDb
Assembly: Interop.BricscadDb (in Interop.BricscadDb.dll) Version: 24.0.0.0
Syntax
public class AcadBlockClass : IAcadBlock, 
        AcadBlock, IAcadObjectEvents_Event, IOdaBlock, IEnumerable

The AcadBlockClass type exposes the following members.

Constructors
  Name Description
Public method AcadBlockClass Initializes a new instance of the AcadBlockClass class
Top
Properties
Methods
  Name Description
Public method add_Modified  
Public method Add3DFace  
Public method Add3DMesh  
Public method Add3DPoly  
Public method AddArc  
Public method AddAttribute  
Public method AddBox  
Public method AddCircle  
Public method AddCone  
Public method AddCustomObject  
Public method AddCylinder  
Public method AddDim3PointAngular  
Public method AddDimAligned  
Public method AddDimAngular  
Public method AddDimArc  
Public method AddDimDiametric  
Public method AddDimOrdinate  
Public method AddDimRadial  
Public method AddDimRadialLarge  
Public method AddDimRotated  
Public method AddEllipse  
Public method AddEllipticalCone  
Public method AddEllipticalCylinder  
Public method AddEmbeddedRaster  
Public method AddExtrudedSolid  
Public method AddExtrudedSolidAlongPath  
Public method AddHatch  
Public method AddLeader  
Public method AddLightWeightPolyline  
Public method AddLine  
Public method AddMInsertBlock  
Public method AddMLeader  
Public method AddMLine  
Public method AddMText  
Public method AddPoint  
Public method AddPolyfaceMesh  
Public method AddPolyline  
Public method AddRaster  
Public method AddRay  
Public method AddRegion  
Public method AddRevolvedSolid  
Public method AddSection  
Public method AddShape  
Public method AddSolid  
Public method AddSphere  
Public method AddSpline  
Public method AddTable  
Public method AddText  
Public method AddTolerance  
Public method AddTorus  
Public method AddTrace  
Public method AddWedge  
Public method AddXline  
Public method AttachExternalReference  
Public method Bind  
Public method Delete  
Public method Detach  
Public method Erase  
Public method GetEnumerator  
Public method GetExtensionDictionary  
Public method GetReferences  
Public method GetXData  
Public method InsertBlock  
Public method IOdaBlock_Add3DFace  
Public method IOdaBlock_Add3DMesh  
Public method IOdaBlock_Add3DPoly  
Public method IOdaBlock_AddArc  
Public method IOdaBlock_AddAttribute  
Public method IOdaBlock_AddBox  
Public method IOdaBlock_AddCircle  
Public method IOdaBlock_AddCone  
Public method IOdaBlock_AddCustomObject  
Public method IOdaBlock_AddCylinder  
Public method IOdaBlock_AddDim3PointAngular  
Public method IOdaBlock_AddDimAligned  
Public method IOdaBlock_AddDimAngular  
Public method IOdaBlock_AddDimArc  
Public method IOdaBlock_AddDimDiametric  
Public method IOdaBlock_AddDimOrdinate  
Public method IOdaBlock_AddDimRadial  
Public method IOdaBlock_AddDimRadialLarge  
Public method IOdaBlock_AddDimRotated  
Public method IOdaBlock_AddEllipse  
Public method IOdaBlock_AddEllipticalCone  
Public method IOdaBlock_AddEllipticalCylinder  
Public method IOdaBlock_AddEmbeddedRaster  
Public method IOdaBlock_AddExtrudedSolid  
Public method IOdaBlock_AddExtrudedSolidAlongPath  
Public method IOdaBlock_AddHatch  
Public method IOdaBlock_AddLeader  
Public method IOdaBlock_AddLightWeightPolyline  
Public method IOdaBlock_AddLine  
Public method IOdaBlock_AddMInsertBlock  
Public method IOdaBlock_AddMLeader  
Public method IOdaBlock_AddMLine  
Public method IOdaBlock_AddMText  
Public method IOdaBlock_AddPoint  
Public method IOdaBlock_AddPolyfaceMesh  
Public method IOdaBlock_AddPolyline  
Public method IOdaBlock_AddRaster  
Public method IOdaBlock_AddRay  
Public method IOdaBlock_AddRegion  
Public method IOdaBlock_AddRevolvedSolid  
Public method IOdaBlock_AddSection  
Public method IOdaBlock_AddShape  
Public method IOdaBlock_AddSolid  
Public method IOdaBlock_AddSphere  
Public method IOdaBlock_AddSpline  
Public method IOdaBlock_AddTable  
Public method IOdaBlock_AddText  
Public method IOdaBlock_AddTolerance  
Public method IOdaBlock_AddTorus  
Public method IOdaBlock_AddTrace  
Public method IOdaBlock_AddWedge  
Public method IOdaBlock_AddXline  
Public method IOdaBlock_AttachExternalReference  
Public method IOdaBlock_Bind  
Public method IOdaBlock_Delete  
Public method IOdaBlock_Detach  
Public method IOdaBlock_Erase  
Public method IOdaBlock_GetEnumerator  
Public method IOdaBlock_GetExtensionDictionary  
Public method IOdaBlock_GetXData  
Public method IOdaBlock_InsertBlock  
Public method IOdaBlock_Item  
Public method IOdaBlock_Reload  
Public method IOdaBlock_SetXData  
Public method IOdaBlock_Unload  
Public method Item  
Public method Reload  
Public method remove_Modified  
Public method setOverlaid  
Public method SetXData  
Public method Unload  
Top
Events
  Name Description
Public event Modified  
Top
See Also

©  Bricsys NV. All rights reserved.