CommonDraw Class

This .NET class wraps the OdGiCommonDraw class which is the base class for entity-level vectorization within the ODA Platform.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceCommonDraw
          Teigha.GraphicsInterfaceViewportDraw
          Teigha.GraphicsInterfaceWorldDraw

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class CommonDraw : RXObject

The CommonDraw type exposes the following members.

Properties
  Name Description
Public property Context Property that represents the context associated with this object.
Public property IsDragging Property that represents a flag that indicates whether this vectorization process is the result of a "drag" operation.
Public property NumberOfIsolines Property that represents a number of isolines to be drawn on surfaces during this vectorization.
Public property RawGeometry Property that provides access to this object's "drawing interface". The "drawing interface" is a set of geometry functions used during the vectorization process.
Public property RegenAbort Property that represents the context associated with this object.
Public property RegenType Property that represents the regeneration type of the current vectorization process.
Public property SubEntityTraits Property that represents subentity traits of this object.
Top
Methods
  Name Description
Public method Deviation Retrieves the recommended maximum deviation of the current vectorization for the specified point on a curve.
Top
See Also

©  Bricsys NV. All rights reserved.