AnnotationScale Class

This class defines an annotation scale as a context object.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesObjectContext
          Teigha.DatabaseServicesAnnotationScale

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class AnnotationScale : ObjectContext

The AnnotationScale type exposes the following members.

Constructors
  Name Description
Public method AnnotationScale Default constructor for the AnnotationScale class.
Top
Properties
  Name Description
Public property CollectionName Property that represents the name of the context collection in which the annotation scale is stored.
(Overrides ObjectContextCollectionName)
Public property DrawingUnits Property that represents drawing units of the annotation scale.
Public property IsTemporaryScale Property that indicates whether annotation scales are stored temporarily in the drawing.
Public property Name Property that represents the name of the annotation scale. It is recommended to access the annotation scale by its unique identifier because an annotation scale name can change.
(Overrides ObjectContextName)
Public property PaperUnits Property that represents paper units. The paper units must be positive and non-zero. Annotation scales are represented as a ratio of paper units to drawing units.
Public property Scale Property that represents paper units. The paper units must be positive and non-zero. Annotation scales are represented as a ratio of paper units to drawing units.
Public property UniqueIdentifier Property that represents a unique identifier of an annotation scale.
(Overrides ObjectContextUniqueIdentifier)
Top
Methods
  Name Description
Top
Remarks
The context is the current viewport scale which can determine the properties of annotations in the viewport. You can get objects of this class using the AnnotationScale context collection. An annotation scale is the ratio of paper units to drawing units, for example, 1 mm to 1 meter for a scale of 0.01.
See Also

©  Bricsys NV. All rights reserved.