Dictionary Class |
The Dictionary type exposes the following members.
Name | Description | |
---|---|---|
![]() |
Dictionary |
Initializes a new instance of the Dictionary class
|
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
Count | |
![]() |
DeletesObjects | |
![]() |
IDictionary_Item | |
![]() |
IsCaseSensitive | |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
IsFixedSize | |
![]() |
IsReadOnly | |
![]() |
IsSorted | |
![]() |
IsSynchronized | |
![]() |
Item | |
![]() |
Keys | |
![]() |
SyncRoot | |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
![]() |
Values |
Name | Description | |
---|---|---|
![]() |
At(Int32) | |
![]() |
At(String) | |
![]() |
AtKeyAndIdPut | |
![]() |
AtPut(Int32, RXObject) | |
![]() |
AtPut(String, RXObject) | |
![]() |
AtPut(String, RXObject, Int32) | |
![]() |
Clone | (Inherited from RXObject.) |
![]() |
CompareTo | (Inherited from RXObject.) |
![]() |
Contains(Int32) | |
![]() |
Contains(String) | |
![]() |
CopyFrom | (Inherited from RXObject.) |
![]() |
CopyTo | |
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
DeleteUnmanagedObject | (Inherited from RXObject.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
Finalize | (Inherited from DisposableWrapper.) |
![]() |
GetEnumerator | |
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetRXClass | (Inherited from RXObject.) |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
ICollection_CopyTo | |
![]() |
IdAt | |
![]() |
IDictionary_Add | |
![]() |
IDictionary_Clear | |
![]() |
IDictionary_Contains | |
![]() |
IDictionary_Remove | |
![]() |
IEnumerable_GetEnumerator | |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
KeyAt | |
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
MemberwiseClone(Boolean) |
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.) |
![]() |
QueryX | (Inherited from RXObject.) |
![]() |
Remove(Int32) | |
![]() |
Remove(String) | |
![]() |
ResetKey(Int32, String) | |
![]() |
ResetKey(String, String) | |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
![]() |
X | (Inherited from RXObject.) |
© Bricsys NV. All rights reserved. |