IFCExportReactor Class

Inheritance Hierarchy
Namespace:  Bricscad.Ifc
Assembly:  BrxMgd (in BrxMgd.dll) Version: 21.0.0.15598
Syntax
public abstract class IFCExportReactor : DisposableWrapper

The IFCExportReactor type exposes the following members.

Constructors
  Name Description
Public method IFCExportReactor
Initializes a new instance of the IFCExportReactor class
Top
Properties
  Name Description
Top
Methods
  Name Description
Public method AdjustProjectData
Public method AttachReactor
Protected method DeleteUnmanagedObject (Overrides DisposableWrapperDeleteUnmanagedObject.)
Public method DetachReactor
Protected method GetAxis2Placement2D
Protected method GetAxis2Placement3D
Protected method GetCartesianPoint2D
Protected method GetCartesianPoint3D
Protected method GetDatabase
Protected method GetDirection2D
Protected method GetDirection3D
Protected method GetIfcModel
Protected method GetProduct(FullSubentityPath)
Protected method GetProduct(ObjectId)
Public method OnBeginIfcModelSetup
Public method OnEndIfcModelSetup
Public method OnEntity
Protected method SetIfcRootData
Protected method SetLocationRelToAssignedSpatialLocation
Protected method SetLocationRelToBuilding
Protected method SetLocationRelToStory
Protected method SetLocationRelToWCS
Protected method SetMaterialToAssignedComposition
Protected method SetMaterialToComposition
Protected method SetRepresentationAsBrep
Protected method SetRepresentationAsClippedExtrudedAreaSolid
Protected method SetRepresentationAsExtrudedAreaSolid
Top
See Also

©  Bricsys NV. All rights reserved.