OdaBlockClass Class

Inheritance Hierarchy
SystemObject
  BricscadDbOdaBlockClass

Namespace: BricscadDb
Assembly: Interop.BricscadDb (in Interop.BricscadDb.dll) Version: 24.0.0.0
Syntax
public class OdaBlockClass : IOdaBlock, 
        OdaBlock, IAcadObjectEvents_Event, IAcadBlock

The OdaBlockClass type exposes the following members.

Constructors
  Name Description
Public method OdaBlockClass Initializes a new instance of the OdaBlockClass class
Top
Properties
Methods
  Name Description
Public method add_Modified  
Public method Add3DFace  
Public method Add3DMesh  
Public method Add3DPoly  
Public method AddArc  
Public method AddAttribute  
Public method AddBox  
Public method AddCircle  
Public method AddCone  
Public method AddCustomObject  
Public method AddCylinder  
Public method AddDim3PointAngular  
Public method AddDimAligned  
Public method AddDimAngular  
Public method AddDimArc  
Public method AddDimDiametric  
Public method AddDimOrdinate  
Public method AddDimRadial  
Public method AddDimRadialLarge  
Public method AddDimRotated  
Public method AddEllipse  
Public method AddEllipticalCone  
Public method AddEllipticalCylinder  
Public method AddEmbeddedRaster  
Public method AddExtrudedSolid  
Public method AddExtrudedSolidAlongPath  
Public method AddHatch  
Public method AddLeader  
Public method AddLightWeightPolyline  
Public method AddLine  
Public method AddMInsertBlock  
Public method AddMLeader  
Public method AddMLine  
Public method AddMText  
Public method AddPoint  
Public method AddPolyfaceMesh  
Public method AddPolyline  
Public method AddRaster  
Public method AddRay  
Public method AddRegion  
Public method AddRevolvedSolid  
Public method AddSection  
Public method AddShape  
Public method AddSolid  
Public method AddSphere  
Public method AddSpline  
Public method AddTable  
Public method AddText  
Public method AddTolerance  
Public method AddTorus  
Public method AddTrace  
Public method AddWedge  
Public method AddXline  
Public method AttachExternalReference  
Public method Bind  
Public method Delete  
Public method Detach  
Public method Erase  
Public method GetEnumerator  
Public method GetExtensionDictionary  
Public method GetReferences  
Public method GetXData  
Public method IAcadBlock_Add3DFace  
Public method IAcadBlock_Add3DMesh  
Public method IAcadBlock_Add3DPoly  
Public method IAcadBlock_AddArc  
Public method IAcadBlock_AddAttribute  
Public method IAcadBlock_AddBox  
Public method IAcadBlock_AddCircle  
Public method IAcadBlock_AddCone  
Public method IAcadBlock_AddCustomObject  
Public method IAcadBlock_AddCylinder  
Public method IAcadBlock_AddDim3PointAngular  
Public method IAcadBlock_AddDimAligned  
Public method IAcadBlock_AddDimAngular  
Public method IAcadBlock_AddDimArc  
Public method IAcadBlock_AddDimDiametric  
Public method IAcadBlock_AddDimOrdinate  
Public method IAcadBlock_AddDimRadial  
Public method IAcadBlock_AddDimRadialLarge  
Public method IAcadBlock_AddDimRotated  
Public method IAcadBlock_AddEllipse  
Public method IAcadBlock_AddEllipticalCone  
Public method IAcadBlock_AddEllipticalCylinder  
Public method IAcadBlock_AddEmbeddedRaster  
Public method IAcadBlock_AddExtrudedSolid  
Public method IAcadBlock_AddExtrudedSolidAlongPath  
Public method IAcadBlock_AddHatch  
Public method IAcadBlock_AddLeader  
Public method IAcadBlock_AddLightWeightPolyline  
Public method IAcadBlock_AddLine  
Public method IAcadBlock_AddMInsertBlock  
Public method IAcadBlock_AddMLeader  
Public method IAcadBlock_AddMLine  
Public method IAcadBlock_AddMText  
Public method IAcadBlock_AddPoint  
Public method IAcadBlock_AddPolyfaceMesh  
Public method IAcadBlock_AddPolyline  
Public method IAcadBlock_AddRaster  
Public method IAcadBlock_AddRay  
Public method IAcadBlock_AddRegion  
Public method IAcadBlock_AddRevolvedSolid  
Public method IAcadBlock_AddSection  
Public method IAcadBlock_AddShape  
Public method IAcadBlock_AddSolid  
Public method IAcadBlock_AddSphere  
Public method IAcadBlock_AddSpline  
Public method IAcadBlock_AddTable  
Public method IAcadBlock_AddText  
Public method IAcadBlock_AddTolerance  
Public method IAcadBlock_AddTorus  
Public method IAcadBlock_AddTrace  
Public method IAcadBlock_AddWedge  
Public method IAcadBlock_AddXline  
Public method IAcadBlock_AttachExternalReference  
Public method IAcadBlock_Bind  
Public method IAcadBlock_Delete  
Public method IAcadBlock_Detach  
Public method IAcadBlock_Erase  
Public method IAcadBlock_GetEnumerator  
Public method IAcadBlock_GetExtensionDictionary  
Public method IAcadBlock_GetXData  
Public method IAcadBlock_InsertBlock  
Public method IAcadBlock_Item  
Public method IAcadBlock_Reload  
Public method IAcadBlock_SetXData  
Public method IAcadBlock_Unload  
Public method InsertBlock  
Public method Item  
Public method Reload  
Public method remove_Modified  
Public method setOverlaid  
Public method SetXData  
Public method Unload  
Top
Events
  Name Description
Public event Modified  
Top
See Also

©  Bricsys NV. All rights reserved.