Constraint3d Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Bricscad.ParametricConstraint3d

Namespace: Bricscad.Parametric
Assembly: BrxMgd (in BrxMgd.dll) Version: 24.0.1.0
Syntax
public class Constraint3d : DisposableWrapper

The Constraint3d type exposes the following members.

Properties
  Name Description
Public property Arguments returns the array of arguments for this constraint object
Public property BlockId returns the owner block table record for this constraint object
Public property ConstraintArguments returns the array of arguments for this constraint object
Public property Dimension returns the associated dimension object for this constraint object
Public property Directions returns the current value of Directions attribute of this constraint object
Public property IsDimensional returns whether this constraint is dimensional or not
Public property IsEnabled returns whether this constraint is enabled or not
Public property Measurement returns the current value of Measurement attribute of this constraint object
Public property Name returns the name of this constraint object
Public property NodeId returns the index of this constraints object, unique within the constraints group
Public property Parameter returns the parameter of dimensional constraint
Public property Placement returns the current value of Placement attribute of this constraint object
Public property Type returns the type of this constraint object
Top
Methods
  Name Description
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Top
See Also

©  Bricsys NV. All rights reserved.