GripData Class

This class describes grip data for entities.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.DatabaseServicesGripData

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class GripData : DisposableWrapper

The GripData type exposes the following members.

Constructors
  Name Description
Protected method GripData Initializes a new instance of the GripData class
Public method GripData(IntPtr) Initializes a new instance of the GripData class
Top
Properties
  Name Description
Public property AlternateBasePoint  
Public property AppData Property that represents the application data associated with this grip object.
Public property DrawAtDragImageGripPoint Property that indicates whether to draw a grip at the drag image grip point.
Public property ForcedPickOn Property that indicates whether all entities within the selection aperture are identified, regardless of whether a point is being acquired or whether any OSNAP modes are currently active.
Public property GizmosEnabled Property that indicates whether gizmos can be used to modify a grip. If this property is true, gizmos appear while hovering the cursor over the grip point.
Public property GripPoint Property that represents the grip point of this object.
Public property HotGripInvokesRightClick Property that indicates whether a hot grip is mapped to a right-click.
Public property IsPerViewport Property that indicates whether this grip is used per viewport.
Public property ModeKeywordsDisabled Property that disables the activation of keywords.
Public property RubberBandLineDisabled Property that indicates whether a rubber-band line is disallowed from being drawn during any drag operations.
Public property SkipWhenShared Property that indicates whether this grip's custom graphic should be skippeed if the grip point for this grip is shared and is about to be drawn.
Public property TriggerGrip Property that indicates whether this grip is a trigger grip.
Top
Methods
  Name Description
Public method CallHotGrip  
Public method CallHoverGrip  
Public method CallRightClick  
Public method CallTooltip  
Public method CallViewportDraw  
Public method CallWorldDraw  
Public method ChangeGripStatus  
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public method GetHotGripDimensionData  
Public method GetHoverDimensionData  
Public method GetTooltip  
Public method OnGripStatusChanged  
Public method OnHotGrip  
Public method OnHover  
Public method OnRightClick  
Public method ViewportDraw  
Public method WorldDraw  
Top
See Also

©  Bricsys NV. All rights reserved.