Device Class |
The Device type exposes the following members.
Name | Description | |
---|---|---|
![]() |
Device |
Default constructor for the Device class.
Creates a graphics device based on an internal pointer to the
wrapped C++ object.
|
![]() |
Device(IntPtr, Boolean) |
Initializes a new instance of the Device class
|
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
BackgroundColor | |
![]() ![]() |
DarkPalette | |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
IsValid | |
![]() ![]() |
LightPalette | |
![]() |
LogicalPalette | |
![]() |
NumViews | |
![]() |
Properties | |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
![]() |
UserGiContext |
Name | Description | |
---|---|---|
![]() |
Add |
Adds a graphics view where drawing is drawn.
Returns true if the view was successfully added to the
device.
|
![]() |
Clone | (Inherited from RXObject.) |
![]() |
CompareTo | (Inherited from RXObject.) |
![]() |
CopyFrom | (Inherited from RXObject.) |
![]() |
CreateModel |
Creates a new model object, and associates it
with this device.
|
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
CreateView |
Creates a new view and associates it with this
device.
|
![]() |
CreateView(ClientViewInfo) |
Creates a new view based on the client view
information and associates it with this device.
|
![]() |
CreateView(ClientViewInfo, Boolean) |
Creates a new view based on the client view
information and associates it with this device.
|
![]() |
DeleteUnmanagedObject | (Overrides RXObjectDeleteUnmanagedObject.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
Erase(Int32) |
Erases a view by the specified index.
|
![]() |
Erase(View) |
Erases the specified view object.
|
![]() |
EraseAll |
Erases all views associated with this
device.
|
![]() |
Finalize | (Inherited from DisposableWrapper.) |
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetImpObj | |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetRXClass | (Inherited from RXObject.) |
![]() |
GetSize |
Retrieves the size of the device.
|
![]() |
GetSizeExt |
Retrieves the extents that represent
dimensions of the device.
|
![]() |
GetSizeRect |
Retrieves the rectangle that represents
dimensions of the device.
|
![]() |
GetSnapshot |
Performs a snapshot of the device's current
graphics status.
|
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
InsertView |
Inserts the specified view object to the
specified position (defined by the viewIndex parameter) in this device.
|
![]() |
Invalidate |
This method is used to signal that the entire
display area is invalid and needs to be refreshed.
|
![]() |
Invalidate(Rectangle) |
This method is used to signal that the
specified display area is invalid area needs to be refreshed.
|
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
MemberwiseClone(Boolean) |
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.) |
![]() |
OnDisplayChange |
Causes this device to accept new screen
resolution and color depth whenever an operating system changes
these parameters.
|
![]() |
OnRealizeBackgroundPalette |
Causes this device to realize its palette in
the background. This method is usually called when the GUI window
loses focus.
|
![]() |
OnRealizeForegroundPalette |
Causes this device to realize its palette in
the foreground. This method is usually called when the GUI window
loses focus.
|
![]() |
OnSize(Rectangle) | |
![]() |
OnSize(Size) | |
![]() |
OnSize(Extents2d) | |
![]() |
QueryX | (Inherited from RXObject.) |
![]() |
SetLogicalPalette |
Sets the logical color palette to be used by
this device. The set palette can later be used for setting indexed
colors.
|
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
![]() |
Update |
Sends the "update" message to all owned views
and forces to display the correct, up to date picture.
|
![]() |
Update(Rectangle) |
Sends the "update" message to all owned views
and forces to display the correct, up to date picture.
|
![]() |
ViewAt |
Retrieves a view by the specified index.
|
![]() |
X | (Inherited from RXObject.) |
© Bricsys NV. All rights reserved. |