ImpDevice Class

Inheritance Hierarchy
Namespace:  Teigha.GraphicsSystem
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public class ImpDevice : Device

The ImpDevice type exposes the following members.

Constructors
  Name Description
Protected method ImpDevice
Initializes a new instance of the ImpDevice class
Top
Properties
Methods
  Name Description
Public method Add (Overrides DeviceAdd(View).)
Public method CreateModel (Overrides DeviceCreateModel.)
Public method CreateView (Overrides DeviceCreateView.)
Public method CreateView(ClientViewInfo) (Overrides DeviceCreateView(ClientViewInfo).)
Public method CreateView(ClientViewInfo, Boolean) (Overrides DeviceCreateView(ClientViewInfo, Boolean).)
Public method Erase(Int32) (Overrides DeviceErase(Int32).)
Public method Erase(View) (Overrides DeviceErase(View).)
Public method EraseAll (Overrides DeviceEraseAll.)
Public method GetSize (Overrides DeviceGetSize.)
Public method GetSizeExt (Overrides DeviceGetSizeExt.)
Public method GetSizeRect (Overrides DeviceGetSizeRect.)
Public method GetSnapshot (Overrides DeviceGetSnapshot(Rectangle).)
Public method InsertView (Overrides DeviceInsertView(Int32, View).)
Public method Invalidate (Overrides DeviceInvalidate.)
Public method Invalidate(Rectangle) (Overrides DeviceInvalidate(Rectangle).)
Public method OnDisplayChange (Overrides DeviceOnDisplayChange(Int32, Int32, Int32).)
Public method OnRealizeBackgroundPalette (Overrides DeviceOnRealizeBackgroundPalette.)
Public method OnRealizeForegroundPalette (Overrides DeviceOnRealizeForegroundPalette.)
Public method OnSize(Rectangle) (Overrides DeviceOnSize(Rectangle).)
Public method OnSize(Size) (Overrides DeviceOnSize(Size).)
Public method OnSize(Extents2d) (Overrides DeviceOnSize(Extents2d).)
Public method SetLogicalPalette (Overrides DeviceSetLogicalPalette(Color).)
Public method Update (Overrides DeviceUpdate.)
Public method Update(Rectangle) (Overrides DeviceUpdate(Rectangle).)
Public method ViewAt (Overrides DeviceViewAt(Int32).)
Top
See Also

©  Bricsys NV. All rights reserved.