BIMRoom Class

Inheritance Hierarchy
Namespace:  Bricscad.Bim
Assembly:  BrxMgd (in BrxMgd.dll) Version: 21.0.0.15598
Syntax
public class BIMRoom : BIMObject

The BIMRoom type exposes the following members.

Constructors
  Name Description
Public method BIMRoom
Initializes a new instance of the BIMRoom class
Public method BIMRoom(BIMRoom)
Initializes a new instance of the BIMRoom class
Public method BIMRoom(ObjectId)
Initializes a new instance of the BIMRoom class
Top
Properties
Methods
  Name Description
Public method AssignToBuilding(BIMBuilding)
Public methodStatic member AssignToBuilding(ObjectId, BIMBuilding)
Public method AssignToStory(BIMStory)
Public methodStatic member AssignToStory(ObjectId, BIMStory)
Public methodStatic member BuildNonAssociativeRoom
Public method CreateAssociativeRoom
Public method CreateNonAssociativeRoom
Public methodStatic member GetAllRooms(Database)
Public methodStatic member GetAllRooms(BIMBuilding, Database)
Public methodStatic member GetAllRooms(BIMStory, Database)
Public method GetAssignedBuilding
Public method GetAssignedLocation
Public method GetAssignedStory
Public method GetBoundingElements
Public method GetOpenings
Public methodStatic member GetRoomArea
Public methodStatic member GetRoomDepartment
Public methodStatic member GetRoomDescription
Public methodStatic member GetRoomIdent
Public methodStatic member GetRoomName
Public methodStatic member GetRoomNumber
Public methodStatic member GetRoomRepresentation
Public method IsAssociativeRoom
Public methodStatic member IsAssociativeRoom(ObjectId)
Public method IsNull (Overrides BIMObjectIsNull.)
Public method SetNull (Overrides BIMObjectSetNull.)
Public methodStatic member SetRoomDepartment
Public methodStatic member SetRoomDescription
Public methodStatic member SetRoomName
Public methodStatic member SetRoomNumber
Public methodStatic member SetRoomRepresentation
Public method UnassignLocation
Public methodStatic member UnassignLocation(ObjectId)
Public method UpdateAssociativeRoom
Top
Operators
  Name Description
Public operatorStatic member Equality
Public operatorStatic member Inequality
Top
See Also

©  Bricsys NV. All rights reserved.