Assoc2dConstraintGroup Class

This .NET class wraps the OdDbAssoc2dConstraintGroup class. The Assoc2dConstraintGroup class represents a set of geometric constraint relations between subentities of geometric entities. All the geometry entities must be coplanar.
Inheritance Hierarchy
Namespace:  Teigha.DatabaseServices
Assembly:  TD_MgdDbConstraints (in TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public class Assoc2dConstraintGroup : AssocAction

The Assoc2dConstraintGroup type exposes the following members.

Constructors
  Name Description
Public method Assoc2dConstraintGroup
Constructor for the Assoc2dConstraintGroup class.
Top
Properties
  Name Description
Public property GetDOF
Public property WorkPlane
Top
Methods
  Name Description
Public method DeleteConstrainedGeometry
Deletes the current ConstrainedGeometry object that is stored internally. This method removes and clears the AssocGeomDependency object from the constraint group action.
Public method RegenDimensionSystem
Regenerates a system of internal dimensions. Only for internal use.
Public method SolutionStatus
Retrieves the solution evaluation status of this constraint group. Call this method only after an evaluation process.
Public method TransformActionBy
Transforms the constraint group work plane by the transformation matrix rigid motion part.
Top
Events
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.