Cell Class

This class represents table cells.
Inheritance Hierarchy
SystemObject
  Teigha.DatabaseServicesCellRange
    Teigha.DatabaseServicesCell

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class Cell : CellRange

The Cell type exposes the following members.

Constructors
  Name Description
Public method Cell Constructor for the Cell class. Creates a cell in the specified table at the given row and column.
Top
Properties
  Name Description
Public property AttachmentPoint  
Public property BlockTableRecordId  
Public property CellType  
Public property Column  
Public property Contents  
Public property ContentTypes  
Public property DataLink  
Public property FieldId  
Public property Row  
Public property TextString  
Public property ToolTip  
Public property Value  
Top
Methods
  Name Description
Public method GetBlockAttributeValue Returns the attribute value for the specified object identifier for this cell.
Public method GetDataLinkRange Returns the data link range of cells.
Public method GetExtents Returns the cell extents for this cell as a collection of 3D points.
Public method GetMergeRange Returns the merge range of this cell. The method returns an invalid merge range if this cell is not part of the merge range.
Public method GetTextString Returns the text string of the cell according to the provided formatting.
Public method GetValue Returns the value of this cell.
Public method RemoveDataLink Removes the data link of this cell.
Public method ResetValue Resets the value in this cell.
Public method SetBlockAttributeValue Sets the attribute value for the specified attribute definition identifier.
Public method SetValue Sets the attribute value for the specified attribute definition identifier.
Public method UpdateDataLink Updates the data link of the cell.
Top
See Also

©  Bricsys NV. All rights reserved.