DistantLightTraits Class

This class wraps the OdGiDistantLightTraits class which represents characteristics for a distant light. This type of light source is located infinitely far from the scene and emits light in a specified direction. For more information, see Working with Lights.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceDrawableTraits
          Teigha.GraphicsInterfaceSubEntityTraits
            Teigha.GraphicsInterfaceNonEntityTraits
              Teigha.GraphicsInterfaceLightTraits
                Teigha.GraphicsInterfaceStandardLightTraits
                  Teigha.GraphicsInterfaceDistantLightTraits

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class DistantLightTraits : StandardLightTraits

The DistantLightTraits type exposes the following members.

Constructors
  Name Description
Public method DistantLightTraits Default constructor for the DistantLightTraits class.
Protected method DistantLightTraits(IntPtr, Boolean) Initializes a new instance of the DistantLightTraits class
Top
Properties
  Name Description
Public property IsSunlight Property that represents a flag that indicates whether this distant light is rendered as sunlight.
Public property LightDirection Property that represents a direction of this distant light.
Top
Methods
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.