SubEntityTraits Class

This class provides an interface to the graphical attributes of graphic primitives.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceDrawableTraits
          Teigha.GraphicsInterfaceSubEntityTraits
            Teigha.GraphicsInterfaceNonEntityTraits
            Teigha.GraphicsInterfaceViewportTraits
            Teigha.GraphicsInterfaceVisualStyleTraits

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class SubEntityTraits : DrawableTraits

The SubEntityTraits type exposes the following members.

Constructors
  Name Description
Protected method SubEntityTraits Initializes a new instance of the SubEntityTraits class
Protected method SubEntityTraits(IntPtr, Boolean) Initializes a new instance of the SubEntityTraits class
Top
Properties
  Name Description
Public property Color Property that represents a subentity color.
Public property DrawFlags Property that represents drawing flags.
Public property FillType Property that represents the current fill type for graphic primitives.
Public property Layer Property that represents a persistent object identifier of a layer.
Public property LineType Property that represents the persistent object identifier of a linetype.
Public property LineTypeScale Property that represents the scale of a linetype.
Public property LineWeight Property that represents a lineweight.
Public property Mapper Property that represents a material mapper.
Public property Material Property that represents the persistent object identifier of a material.
Public property PlotStyleDescriptor Property that represents a plot style descriptor.
Public property Sectionable Property that indicates whether this entity is sectionable.
Public property SelectionFlags Property that represents section flags.
Public property SelectionOnlyGeometry Property that indicates whether only geometry is selected.
Public property ShadowFlags Property that represents shadow flags.
Public property Thickness Property that represents thickness.
Public property Transparency Property that represents the transparency of a sub-entity.
Public property TrueColor Property that represents the true color of a subentity.
Public property VisualStyle Property that represents the persistent object identifier of a visual style.
Top
Methods
  Name Description
Public method SetSelectionMarker Sets the current selection marker.
Top
Remarks
This object is available during calls to subWorldDraw and subViewportDraw, so that drawable classes can control attributes during the vectorization process. Graphical attribute settings are used for all graphical primitives until they are changed.
See Also

©  Bricsys NV. All rights reserved.