VisualStyleTraits Class

This class represents visual style traits. This class enables the interfaces to implement setting and getting the visual style through drawable traits. For more information, see Working with Visual Styles.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceDrawableTraits
          Teigha.GraphicsInterfaceSubEntityTraits
            Teigha.GraphicsInterfaceVisualStyleTraits

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class VisualStyleTraits : SubEntityTraits

The VisualStyleTraits type exposes the following members.

Constructors
  Name Description
Protected method VisualStyleTraits Initializes a new instance of the VisualStyleTraits class
Top
Properties
  Name Description
Public property OdGiVisualStyle Property that represents an associated visual style.
Top
Methods
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.