Ground
|
The GroundPlaneBackgroundTraits type exposes the following members.
Name | Description | |
---|---|---|
![]() |
GroundPlaneBackgroundTraits | Default constructor for the GroundPlaneBackgroundTraits class. |
![]() |
GroundPlaneBackgroundTraits(IntPtr, Boolean) | Constructor for the GroundPlaneBackgroundTraits class. Creates an object based on the passed pointer. |
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
![]() |
Color | (Inherited from NonEntityTraits) |
![]() |
ColorGroundPlaneFar | Property that represents a color of the far ground plane. |
![]() |
ColorGroundPlaneNear | Property that represents a color of the near ground plane. |
![]() |
ColorSkyHorizon | Property that represents a color of the sky horizon. |
![]() |
ColorSkyZenith | Property that represents a color of the sky zenith. |
![]() |
ColorUndergroundAzimuth | Property that represents a color of the underground azimuth. |
![]() |
ColorUndergroundHorizon | Property that represents a color of the underground horizon. |
![]() |
DrawFlags | (Inherited from NonEntityTraits) |
![]() |
FillType | (Inherited from NonEntityTraits) |
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
![]() |
Layer | (Inherited from NonEntityTraits) |
![]() |
LineType | (Inherited from NonEntityTraits) |
![]() |
LineTypeScale | (Inherited from NonEntityTraits) |
![]() |
LineWeight | (Inherited from NonEntityTraits) |
![]() |
Mapper | (Inherited from NonEntityTraits) |
![]() |
Material | (Inherited from NonEntityTraits) |
![]() |
PlotStyleDescriptor | (Inherited from NonEntityTraits) |
![]() |
Sectionable | (Inherited from NonEntityTraits) |
![]() |
SelectionFlags | (Inherited from NonEntityTraits) |
![]() |
SelectionOnlyGeometry | (Inherited from NonEntityTraits) |
![]() |
ShadowFlags | (Inherited from NonEntityTraits) |
![]() |
Thickness | (Inherited from NonEntityTraits) |
![]() |
Transparency | (Inherited from NonEntityTraits) |
![]() |
TrueColor | (Inherited from NonEntityTraits) |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
![]() |
VisualStyle | (Inherited from NonEntityTraits) |
Name | Description | |
---|---|---|
![]() |
AddLight | Drawables that emit light can add one or more lights to the
model. Through this interface, light position, intensity and other
properties are sent to the graphics system. Default implementation
of this method throws the NotSupportedException exception. (Inherited from NonEntityTraits) |
![]() |
Clone | (Inherited from RXObject) |
![]() |
CompareTo | (Inherited from RXObject) |
![]() |
CopyFrom | (Inherited from RXObject) |
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
DeleteUnmanagedObject | (Inherited from RXObject) |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper) |
![]() |
Equals | (Inherited from DisposableWrapper) |
![]() |
Finalize | (Inherited from DisposableWrapper) |
![]() |
GetHashCode | (Inherited from DisposableWrapper) |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetRXClass | (Inherited from RXObject) |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object) |
![]() |
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject
object. (Inherited from MarshalByRefObject) |
![]() |
QueryX | (Inherited from RXObject) |
![]() |
SetLayerFlags | (Inherited from NonEntityTraits) |
![]() |
SetSelectionMarker | Sets the SubEntityTraits object to use the specified graphics
marker for all graphics primitives drawn until the next call to
this function, or the end of WorldDraw() or ViewportDraw()
execution. Default implementation of this method throws the
NotSupportedException exception. (Inherited from NonEntityTraits) |
![]() |
SetupForEntity | Initializes all subentity traits and drawable traits from the
entity. This can be more convenient than setting each property
individually. Default implementation of this method throws the
NotSupportedException exception. (Inherited from NonEntityTraits) |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
![]() |
X | (Inherited from RXObject) |
© Bricsys NV. All rights reserved. |