Inheritance Hierarchy
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public sealed class Sphere : Surface
Public NotInheritable Class Sphere
Inherits Surface
public ref class Sphere sealed : public Surface
[<SealedAttribute>]
type Sphere =
class
inherit Surface
end
The Sphere type exposes the
following members.
Constructors
Properties
Methods
|
Name |
Description |
|
Clone
|
(Inherited from Entity3d.) |
|
ClosestPointTo(Point3d)
|
(Inherited from Surface.) |
|
ClosestPointTo(Point3d,
Tolerance)
|
(Inherited from Surface.) |

|
Create
|
|
|
CreateObjRef
|
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
|
Dispose
|
(Inherited from DisposableWrapper.) |
|
DistanceTo(Point3d)
|
(Inherited from Surface.) |
|
DistanceTo(Point3d,
Tolerance)
|
(Inherited from Surface.) |
|
Equals
|
(Inherited from DisposableWrapper.) |
|
EvaluatePoint
|
(Inherited from Surface.) |
|
GetAnglesInU
|
|
|
GetAnglesInV
|
|
|
GetClosestPointTo(Point3d)
|
(Inherited from Surface.) |
|
GetClosestPointTo(Point3d,
Tolerance)
|
(Inherited from Surface.) |
|
GetEnvelope
|
(Inherited from Surface.) |
|
GetHashCode
|
(Inherited from DisposableWrapper.) |
|
GetLifetimeService
|
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
|
GetType
|
Gets the Type of the current instance.
(Inherited from Object.) |
|
InitializeLifetimeService
|
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
|
IntersectWith(LinearEntity3d)
|
|
|
IntersectWith(LinearEntity3d,
Tolerance)
|
|
|
IsClosed
|
|
|
IsClosed(Tolerance)
|
|
|
IsClosedInU
|
(Inherited from Surface.) |
|
IsClosedInU(Tolerance)
|
(Inherited from Surface.) |
|
IsClosedInV
|
(Inherited from Surface.) |
|
IsClosedInV(Tolerance)
|
(Inherited from Surface.) |
|
IsEqualTo(Entity3d)
|
(Inherited from Entity3d.) |
|
IsEqualTo(Entity3d,
Tolerance)
|
(Inherited from Entity3d.) |
|
IsOn(Point3d)
|
(Inherited from Entity3d.) |
|
IsOn(Point3d,
Tolerance)
|
(Inherited from Entity3d.) |
|
IsOn(Point3d,
Point2d)
|
(Inherited from Surface.) |
|
IsOn(Point3d,
Point2d, Tolerance)
|
(Inherited from Surface.) |
|
Mirror
|
(Inherited from Entity3d.) |
|
ParameterOf(Point3d)
|
(Inherited from Surface.) |
|
ParameterOf(Point3d,
Tolerance)
|
(Inherited from Surface.) |
|
RotateBy
|
(Inherited from Entity3d.) |
|
ScaleBy
|
(Inherited from Entity3d.) |
|
Set(Double,
Point3d)
|
|
|
Set(Double,
Point3d, Vector3d, Vector3d, Double, Double, Double, Double)
|
|
|
SetAnglesInU
|
|
|
SetAnglesInV
|
|
|
ToString
|
Returns a string that represents the current
object.
(Inherited from Object.) |
|
TransformBy
|
(Inherited from Entity3d.) |
|
TranslateBy
|
(Inherited from Entity3d.) |
Top
See Also