ImageBackgroundTraits Class

This class represents traits that are related to image-based backgrounds.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceDrawableTraits
          Teigha.GraphicsInterfaceSubEntityTraits
            Teigha.GraphicsInterfaceNonEntityTraits
              Teigha.GraphicsInterfaceImageBackgroundTraits

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class ImageBackgroundTraits : NonEntityTraits

The ImageBackgroundTraits type exposes the following members.

Constructors
  Name Description
Protected method ImageBackgroundTraits Initializes a new instance of the ImageBackgroundTraits class
Protected method ImageBackgroundTraits(IntPtr, Boolean) Creates an object based on the passed pointer and returns a handle to the created object.
Top
Properties
  Name Description
Public property FitToScreen Property that indicates whether image-based background should be fit to screen.
Public property ImageFilename Property that represents the full path to the file from which this image-based background is created.
Public property MaintainAspectRatio Property that indicates whether to maintain the aspect ratio of a background image.
Public property UseTiling Property that indicates whether this image-based background is tiled.
Public property XOffset Property that represents the offset of a background on the x-axis. Negative values mean that the background is offset in the opposite direction of the x-axis.
Public property XScale Property that represents the scale of a background on the x-axis. Values between 0 and 1 mean that the background is shrunk on the x-axis, values greater than 1 mean that the background is stretched, and negative values mean that the background is flipped on the x-axis.
Public property YOffset Property that represents the offset of a background on the y-axis. Negative values mean that the background is offset in the opposite direction of the y-axis.
Public property YScale Property that represents the scale of a background on the y-axis. Values between 0 and 1 mean that the background is shrunk on the y-axis, values greater than 1 mean that the background is stretched, and negative values mean that the background is flipped on the y-axis.
Top
Methods
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.