Device Class

This .NET class wraps the OdGsDevice class. The device is the abstract representation of the GUI window where the drawing is displayed. In addition, it responds to operating system notifications, such as window resizing, that are forwarded by the graphics system client. For more information, see Working with Graphic Devices.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsSystemDevice
          Teigha.GraphicsSystemImpDevice

Namespace: Teigha.GraphicsSystem
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class Device : RXObject

The Device type exposes the following members.

Constructors
  Name Description
Public method Device Default constructor for the Device class. Creates a graphics device based on an internal pointer to the wrapped C++ object.
Protected method Device(IntPtr, Boolean) Initializes a new instance of the Device class
Top
Properties
  Name Description
Public property BackgroundColor Property that represents the background color of the GUI window of this Device object.
Public propertyStatic member DarkPalette Property that represents the palette for dark background colors used by this Device object.
Public property IsValid Property that indicates whether the GUI window for this Device object is showing the correct image.
Public propertyStatic member LightPalette Property that represents the palette for light background colors used by this Device object.
Public property LogicalPalette Property that represents the logical palette to be used by this Device object.
Public property NumViews Property that represents the number of views associated with this Device object.
Public property Properties Property that represents a set of device properties stored in a dictionary. For more information, see ODA Vectorization Devices Properties.
Public property UserGiContext Property that represents user context for the graphics interface.
Top
Methods
  Name Description
Public method Add Adds a graphics view where drawing is drawn. Returns true if the view was successfully added to the device.
Public method CreateModel Creates a new model object, and associates it with this device.
Public method CreateView Creates a new view and associates it with this device.
Public method CreateView(ClientViewInfo) Creates a new view based on the client view information and associates it with this device.
Public method CreateView(ClientViewInfo, Boolean) Creates a new view based on the client view information and associates it with this device.
Protected method DeleteUnmanagedObject
(Overrides RXObjectDeleteUnmanagedObject)
Public method Erase(Int32) Erases a view by the specified index.
Public method Erase(View) Erases the specified view object.
Public method EraseAll Erases all views associated with this device.
Protected method GetImpObj  
Public method GetSize Retrieves the size of the device.
Public method GetSizeExt Retrieves the extents that represent dimensions of the device.
Public method GetSizeRect Retrieves the rectangle that represents dimensions of the device.
Public method GetSnapshot Performs a snapshot of the device's current graphics status.
Public method InsertView Inserts the specified view object to the specified position (defined by the viewIndex parameter) in this device.
Public method Invalidate This method is used to signal that the entire display area is invalid and needs to be refreshed.
Public method Invalidate(Rectangle) This method is used to signal that the specified display area is invalid area needs to be refreshed.
Public method OnDisplayChange Causes this device to accept new screen resolution and color depth whenever an operating system changes these parameters.
Public method OnRealizeBackgroundPalette Causes this device to realize its palette in the background. This method is usually called when the GUI window loses focus.
Public method OnRealizeForegroundPalette Causes this device to realize its palette in the foreground. This method is usually called when the GUI window loses focus.
Public method OnSize(Extents2d)  
Public method OnSize(Rectangle)  
Public method OnSize(Size)  
Public method SetLogicalPalette Sets the logical color palette to be used by this device. The set palette can later be used for setting indexed colors.
Public method Update Sends the "update" message to all owned views and forces to display the correct, up to date picture.
Public method Update(Rectangle) Sends the "update" message to all owned views and forces to display the correct, up to date picture.
Public method ViewAt Retrieves a view by the specified index.
Top
See Also

©  Bricsys NV. All rights reserved.