ImpDevice Class

This class represents an implementation of a graphics device (Device object).
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsSystemDevice
          Teigha.GraphicsSystemImpDevice
            Teigha.GraphicsSystemLayoutHelperDevice

Namespace: Teigha.GraphicsSystem
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class ImpDevice : Device

The ImpDevice type exposes the following members.

Constructors
  Name Description
Protected method ImpDevice Initializes a new instance of the ImpDevice class
Top
Properties
  Name Description
Public property BackgroundColor Property that represents the background color of the GUI window of the Device object.
(Overrides DeviceBackgroundColor)
Public property IsValid Property that indicates whether the GUI window for the Device object is showing the correct image.
(Overrides DeviceIsValid)
Public property LogicalPalette Property that represents the logical palette to be used by the Device object.
(Overrides DeviceLogicalPalette)
Public property NumViews Property that represents the number of views associated with the Device object.
(Overrides DeviceNumViews)
Public property Properties Property that represents a set of device properties stored in a dictionary. For more information, see ODA Vectorization Device Properties.
(Overrides DeviceProperties)
Public property UserGiContext Property that represents user context for the graphics interface.
(Overrides DeviceUserGiContext)
Top
Methods
  Name Description
Public method Add Adds a graphics view where the drawing is drawn.
(Overrides DeviceAdd(View))
Public method CreateModel Creates a new model object and associates it with this device.
(Overrides DeviceCreateModel)
Public method CreateView Creates a new view and associates it with this device.
(Overrides DeviceCreateView)
Public method CreateView(ClientViewInfo) Creates a new view based on the client view information and associates it with this device.
(Overrides DeviceCreateView(ClientViewInfo))
Public method CreateView(ClientViewInfo, Boolean) Creates a new view based on the client view information and associates it with this device.
(Overrides DeviceCreateView(ClientViewInfo, Boolean))
Public method Erase(Int32) Erases a view by the specified index.
(Overrides DeviceErase(Int32))
Public method Erase(View) Erases the specified view object.
(Overrides DeviceErase(View))
Public method EraseAll Erases all views associated with this device.
(Overrides DeviceEraseAll)
Public method GetSize Retrieves the size of the device.
(Overrides DeviceGetSize)
Public method GetSizeExt Retrieves the extents that represent the dimensions of the device.
(Overrides DeviceGetSizeExt)
Public method GetSizeRect Retrieves the rectangle that represents the dimensions of the device.
(Overrides DeviceGetSizeRect)
Public method GetSnapshot Performs a snapshot of the device's current graphics status.
(Overrides DeviceGetSnapshot(Rectangle))
Public method InsertView Inserts the specified view object to the specified position (defined by the viewIndex parameter) in this device.
(Overrides DeviceInsertView(Int32, View))
Public method Invalidate This method is used to signal that the entire display area is invalid and needs to be refreshed.
(Overrides DeviceInvalidate)
Public method Invalidate(Rectangle) This method is used to signal that the specified display area is invalid and needs to be refreshed.
(Overrides DeviceInvalidate(Rectangle))
Public method OnDisplayChange Causes this device to accept a new screen resolution and color depth whenever the operating system changes these parameters.
(Overrides DeviceOnDisplayChange(Int32, Int32, Int32))
Public method OnRealizeBackgroundPalette Causes this device to realize its palette in the background. This method is usually called when the GUI window loses focus.
(Overrides DeviceOnRealizeBackgroundPalette)
Public method OnRealizeForegroundPalette Causes this device to realize its palette in the foreground. This method is usually called when the GUI window loses focus.
(Overrides DeviceOnRealizeForegroundPalette)
Public method OnSize(Extents2d)
(Overrides DeviceOnSize(Extents2d))
Public method OnSize(Rectangle)
(Overrides DeviceOnSize(Rectangle))
Public method OnSize(Size)
(Overrides DeviceOnSize(Size))
Public method SetLogicalPalette Sets the logical color palette to be used by this device. The set palette can later be used for setting indexed colors.
(Overrides DeviceSetLogicalPalette(Color))
Public method Update Sends the "update" message to all owned views and forces the display of the correct, up-to-date picture.
(Overrides DeviceUpdate)
Public method Update(Rectangle) Sends the "update" message to all owned views and forces the display of the correct, up-to-date picture.
(Overrides DeviceUpdate(Rectangle))
Public method ViewAt Retrieves a view by the specified index.
(Overrides DeviceViewAt(Int32))
Top
See Also

©  Bricsys NV. All rights reserved.