EdgeStyle Class

This class wraps the OdGiEdgeStyle class which defines a set of visual style properties that can be applied to the edges of graphical entities. For more information, see Working with Visual Styles.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceEdgeStyle

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class EdgeStyle : RXObject, 
        ICloneable

The EdgeStyle type exposes the following members.

Constructors
  Name Description
Public method EdgeStyle Default constructor for the EdgeStyle class.
Top
Properties
  Name Description
Public property CreaseAngle  
Public property EdgeColor Property that represents the color of an edge.
Public property EdgeModel Property that represents a model for displaying edges.
Public property EdgeModifiers Property that represents modifiers applied to edges to give them various visual effects.
Public property EdgeStyleApply Property that represents the type of geometry to which the edge styles should be applied.
Public property EdgeVisibility Property that represents visibility modes for edges.
Public property EdgeWidth Property that represents an edge width.
Public property HaloGap Property that represents a halo gap amount (in the range [0..100]).
Public property HidePrecision  
Public property IntersectionColor Property that represents the color of edges in the intersection of graphical objects.
Public property IntersectionLinetype Property that represents the linetype used for edges in the intersection of graphical objects.
Public property Isolines  
Public property Jitter Property that represents the amount of jitter effect for edges (low, medium or high perturbation).
Public property ObscuredColor Property that represents the color of obscured edges.
Public property ObscuredLinetype Property that represents the linetype for obscured edges.
Public property Opacity Property that represents edge opacity.
Public property Overhang Property that represents an edge overhang amount.
Public property SilhouetteColor Property that represents the silhouette color of an edge.
Public property SilhouetteWidth  
Top
Methods
  Name Description
Public method Clone Clones the current edge style and returns a handle to the cloned object.
Public method Set Sets edge styles from the passed EdgeStyle object.
Top
See Also

©  Bricsys NV. All rights reserved.