GradientBackgroundTraits Class

This class represents traits that are related to gradient backgrounds.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceDrawableTraits
          Teigha.GraphicsInterfaceSubEntityTraits
            Teigha.GraphicsInterfaceNonEntityTraits
              Teigha.GraphicsInterfaceGradientBackgroundTraits

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class GradientBackgroundTraits : NonEntityTraits

The GradientBackgroundTraits type exposes the following members.

Constructors
  Name Description
Protected method GradientBackgroundTraits Initializes a new instance of the GradientBackgroundTraits class
Protected method GradientBackgroundTraits(IntPtr, Boolean) Initializes a new instance of the GradientBackgroundTraits class
Top
Properties
  Name Description
Public property ColorBottom Property that represents the bottom color of this gradient background.
Public property ColorMiddle Property that represents the middle color of this gradient background.
Public property ColorTop Property that represents the top color of this gradient background.
Public property Height Property that represents the height of the middle color of this gradient background.
Public property Horizon Property that represents the horizon of this gradient background.
Public property Rotation Property that represents the rotation (in degrees) of this gradient background.
Top
Methods
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.