IFCExportReactor Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Bricscad.IfcIFCExportReactor

Namespace: Bricscad.Ifc
Assembly: BrxMgd (in BrxMgd.dll) Version: 24.0.1.0
Syntax
public abstract class IFCExportReactor : DisposableWrapper

The IFCExportReactor type exposes the following members.

Constructors
  Name Description
Public method IFCExportReactor Initializes a new instance of the IFCExportReactor class
Top
Properties
  Name Description
Public property CurrentContext  
Top
Methods
  Name Description
Public method AdjustProjectData(IfcProjectData) Obsolete.
Public method AdjustProjectData(ExportContext, IfcProjectData)  
Public method AttachReactor  
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public method DetachReactor  
Protected method GetAxis2Placement2D Obsolete.
Protected method GetAxis2Placement3D Obsolete.
Protected method GetCartesianPoint2D Obsolete.
Protected method GetCartesianPoint3D Obsolete.
Protected method GetDatabase Obsolete.
Protected method GetDirection2D Obsolete.
Protected method GetDirection3D Obsolete.
Protected method GetIfcModel Obsolete.
Protected method GetProduct(FullSubentityPath) Obsolete.
Protected method GetProduct(ObjectId) Obsolete.
Public method OnBeginIfcModelSetup Obsolete.
Public method OnBeginIfcModelSetup(ExportContext)  
Public method OnEndIfcModelSetup Obsolete.
Public method OnEndIfcModelSetup(ExportContext)  
Public method OnEntity(Entity) Obsolete.
Public method OnEntity(ExportContext, Entity)  
Protected method SetIfcRootData Obsolete.
Protected method SetLocationRelToAssignedSpatialLocation Obsolete.
Protected method SetLocationRelToBuilding Obsolete.
Protected method SetLocationRelToStory Obsolete.
Protected method SetLocationRelToWCS Obsolete.
Protected method SetMaterialToAssignedComposition Obsolete.
Protected method SetMaterialToComposition Obsolete.
Protected method SetRepresentationAsBrep Obsolete.
Protected method SetRepresentationAsClippedExtrudedAreaSolid Obsolete.
Protected method SetRepresentationAsExtrudedAreaSolid Obsolete.
Top
See Also

©  Bricsys NV. All rights reserved.