GIRasterImageDesc Class

This class is a dummy implementation of the GIRasterImage interface.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceGIRasterImage
          Teigha.GraphicsInterfaceGIRasterImageDesc

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class GIRasterImageDesc : GIRasterImage

The GIRasterImageDesc type exposes the following members.

Constructors
  Name Description
Protected method GIRasterImageDesc(IntPtr, Boolean) Initializes a new instance of the GIRasterImageDesc class
Public method GIRasterImageDesc(UInt32, UInt32) Constructor for the GIRasterImageDesc class. Constructs a raster image of the specified width and height in pixels.
Public method GIRasterImageDesc(UInt32, UInt32, Units) Constructor for the GIRasterImageDesc class. Constructs a raster image of the specified width, height, and units for the raster image.
Public method GIRasterImageDesc(UInt32, UInt32, Units, Double, Double) Constructor for the GIRasterImageDesc class. Constructs a raster image of the specified width, height, and units for the raster image, and the pixels per unit values for x- and y-directions.
Top
Properties
  Name Description
Top
Methods
  Name Description
Public method SetColorDepth Sets the number of bits per pixel used by this raster image for colors.
Public method SetImageSource Sets an image source.
Public method SetPalette Sets the palette in BMP format for this raster image.
Public method SetPixelHeight Sets the image height in pixels for this raster image.
Public method SetPixelWidth Sets the image width in pixels for this raster image.
Public method SetScanLinesAlignment Sets the scanline alignment, in bytes, for this raster image.
Public method SetTransparencyMode Sets an image transparency mode.
Public method SupportedParams Retrieves the bitflags with which parameters are supported by this interface.
Top
See Also

©  Bricsys NV. All rights reserved.