ViewportTraits Class

This class gives viewports the opportunity to pass per-viewport properties to the display and rendering systems.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceDrawableTraits
          Teigha.GraphicsInterfaceSubEntityTraits
            Teigha.GraphicsInterfaceViewportTraits

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class ViewportTraits : SubEntityTraits

The ViewportTraits type exposes the following members.

Constructors
  Name Description
Public method ViewportTraits Default constructor for the ViewportTraits class.
Protected method ViewportTraits(IntPtr, Boolean) Initializes a new instance of the ViewportTraits class
Top
Properties
  Name Description
Public property AmbientLightColor Property that represents the ambient color (color in the shadows) of this viewport.
Public property Background Property that represents the persistent object identifier of a background for this viewport.
Public property Brightness Property that represents the brightness of this viewport in the range [0..200].
Public property Contrast Property that represents the contrast of this viewport in the range [0..100].
Public property DefaultLightingOn Property that indicates whether default lighting is turned on.
Public property DefaultLightingType Property that represents the default lighting type for this viewport.
Public property RenderEnvironment Property that represents a persistent object identifier of a render environment for this viewport. Used only in full renders.
Public property RenderSettings Property that represents a persistent object identifier of render settings for this viewport. Used only in full renders.
Top
Methods
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.