Surface Class

This class is the base class for all parametric surfaces. For more information, see Working with Surfaces.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        Teigha.GeometrySurface
          More

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class Surface : Entity3d

The Surface type exposes the following members.

Properties
  Name Description
Public property IsNormalReversed Property that indicates whether the normal of this surface is reversed an odd number of times.
Public property ReverseNormal Property that creates a surface with a reversed normal vector orientation (the same exact surface but with changed normal orientation).
Top
Methods
  Name Description
Public method ClosestPointTo(Point3d) Gets a point on this surface that is the closest to the specified point.
Public method ClosestPointTo(Point3d, Tolerance) Gets a point on this surface that is the closest to the specified point according to a tolerance.
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Public method DistanceTo(Point3d) Retrieves the distance from the closest point on this plane to the specified point.
Public method DistanceTo(Point3d, Tolerance) Retrieves the distance from the closest point on this plane to the specified point according to a tolerance.
Public method EvaluatePoint Retrieves the 3D point on this surface that corresponds to the specified point parameter value.
Public method GetClosestPointTo(Point3d) Gets a point on this surface that is the closest to the specified point.
Public method GetClosestPointTo(Point3d, Tolerance) Gets a point on this surface that is the closest to the specified point according to a tolerance.
Public method GetEnvelope  
Public method IsClosedInU  
Public method IsClosedInU(Tolerance)  
Public method IsClosedInV  
Public method IsClosedInV(Tolerance)  
Public method IsOn(Point3d, Point2d)  
Public method IsOn(Point3d, Point2d, Tolerance)  
Public method ParameterOf(Point3d) Retrieves a 2D point (U, V) that represents parametric values for the passed 3D point on this surface.
Public method ParameterOf(Point3d, Tolerance) Retrieves a 2D point (U, V) that represents parametric values for the passed 3D point on this surface.
Top
See Also
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        Teigha.GeometrySurface
          Teigha.GeometryCone
          Teigha.GeometryCylinder
          Teigha.GeometryEllipticalCone
          Teigha.GeometryEllipticalCylinder
          Teigha.GeometryExternalBoundedSurface
          Teigha.GeometryExternalSurface
          Teigha.GeometryNurbSurface
          Teigha.GeometryOffsetSurface
          Teigha.GeometryPlanarEntity
          Teigha.GeometrySphere
          Teigha.GeometryTorus

©  Bricsys NV. All rights reserved.