Dwg
|
The DwgFiler type exposes the following members.
Name | Description | |
---|---|---|
![]() |
DwgFiler | Initializes a new instance of the DwgFiler class |
![]() |
DwgFiler(IntPtr, Boolean) | Initializes a new instance of the DwgFiler class |
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
![]() |
Database | Property that represents the database with which this Filer object is associated. |
![]() |
DwgVersion | Property that represents the version of this file with which this Filer object is associated. |
![]() |
FilerStatus | Property that represents the current status of this Filer object. |
![]() |
FilerType | Property that represents the type of this Filer object. |
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
![]() |
Position | Property that represents the current I/O pointer position of this Filer object. |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
Name | Description | |
---|---|---|
![]() |
Clone | (Inherited from RXObject) |
![]() |
CompareTo | (Inherited from RXObject) |
![]() |
CopyFrom | (Inherited from RXObject) |
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
DeleteUnmanagedObject | (Inherited from RXObject) |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper) |
![]() |
Equals | (Inherited from DisposableWrapper) |
![]() |
Finalize | (Inherited from DisposableWrapper) |
![]() |
GetHashCode | (Inherited from DisposableWrapper) |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetRXClass | (Inherited from RXObject) |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object) |
![]() |
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject
object. (Inherited from MarshalByRefObject) |
![]() |
QueryX | (Inherited from RXObject) |
![]() |
ReadAddress | Returns the memory address value of the current item of this Filer object. |
![]() |
ReadBinaryChunk | Returns the BinaryData value of the current item of this Filer object. |
![]() |
ReadBoolean | Returns the Boolean value of the current item of this Filer object. |
![]() |
ReadByte | Returns the UInt8 value of the current item of this Filer object. |
![]() |
ReadBytes | Returns the specified number of bytes from this Filer object. |
![]() |
ReadDouble | Returns the double value of the current item of this Filer object. |
![]() |
ReadHandle | Returns the handle value of the current item of this Filer object. |
![]() |
ReadHardOwnershipId | Returns the HardOwnershipId value of the current item of this Filer object. |
![]() |
ReadHardPointerId | Returns the HardPointerId value of the current item of this Filer object. |
![]() |
ReadInt16 | Returns the Int16 value of the current item of this Filer object. |
![]() |
ReadInt32 | Returns the Int32 value of the current item of this Filer object. |
![]() |
ReadInt64 | Returns the Int64 value of the current item of this Filer object. |
![]() |
ReadPoint2d | Returns the 2D point of the current item of this Filer object. |
![]() |
ReadPoint3d | Returns the 3D point of the current item of this Filer object. |
![]() |
ReadScale3d | Returns the scale value of the current item of this Filer object. |
![]() |
ReadSoftOwnershipId | Returns the SoftOwnershipId value of the current item of this Filer object. |
![]() |
ReadSoftPointerId | Returns the SoftPointerId value of the current item of this Filer object. |
![]() |
ReadString | Returns the string value of the current item of this Filer object. |
![]() |
ReadUInt16 | Returns the UInt16 value of the current item of this Filer object. |
![]() |
ReadUInt32 | Returns the UInt32 value of the current item of this Filer object. |
![]() |
ReadUInt64 | Returns the UInt64 value of the current item of this Filer object. |
![]() |
ReadVector2d | Returns the 2D vector of the current item of this Filer object. |
![]() |
ReadVector3d | Returns the 3D vector of the current item of this Filer object. |
![]() |
ResetFilerStatus | Resets the current status of this Filer object. |
![]() |
Seek | Moves the I/O pointer to the specified location in this Filer object. |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
![]() |
WriteAddress | Writes the specified memory address value to this Filer object. |
![]() |
WriteBinaryChunk | Writes the specified BinaryChunk value to this Filer object. |
![]() |
WriteBoolean | Writes the specified Boolean value to this Filer object. |
![]() |
WriteByte | Writes the specified byte to this Filer object. |
![]() |
WriteBytes | Writes the specified number of bytes to this Filer object. |
![]() |
WriteDouble | Writes the specified double value to this Filer object. |
![]() |
WriteHandle | Writes the specified handle value to this Filer object. |
![]() |
WriteHardOwnershipId | Writes the specified HardOwnershipId value to this Filer object. |
![]() |
WriteHardPointerId | Writes the specified HardPointerId value to this Filer object. |
![]() |
WriteInt16 | Writes the specified Int16 value to this Filer object. |
![]() |
WriteInt32 | Writes the specified Int32 value to this Filer object. |
![]() |
WriteInt64 | Writes the specified Int64 value to this Filer object. |
![]() |
WritePoint2d | Writes the specified 2D point to this Filer object. |
![]() |
WritePoint3d | Writes the specified 3D point to this Filer object. |
![]() |
WriteScale3d | Writes the specified scale value to this Filer object. |
![]() |
WriteSoftOwnershipId | Writes the specified SoftOwnershipId value to this Filer object. |
![]() |
WriteSoftPointerId | Writes the specified SoftPointerId value to this Filer object. |
![]() |
WriteString | Writes the specified string value to this Filer object. |
![]() |
WriteUInt16 | Writes the specified UInt16 value to this Filer object. |
![]() |
WriteUInt32 | Writes the specified UInt32 value to this Filer object. |
![]() |
WriteUInt64 | Writes the specified UInt64 value to this Filer object. |
![]() |
WriteVector2d | Writes the specified 2D vector to this Filer object. |
![]() |
WriteVector3d | Writes the specified 3D vector to this Filer object. |
![]() |
X | (Inherited from RXObject) |
© Bricsys NV. All rights reserved. |