Variant Class

This class is used as the basis for the generic data storage used for procedural material definitions.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceVariant

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class Variant : RXObject

The Variant type exposes the following members.

Constructors
  Name Description
Public method Variant Default constructor for the Variant class. Constructs a variant of undefined type without a value.
Public method Variant(Boolean) Constructor for the Variant class. Constructs a variant with the specified value of the bool type.
Public method Variant(Color) Constructor for the Variant class. Constructs a variant with the specified color value.
Public method Variant(Double) Constructor for the Variant class. Constructs a variant with the specified value of the double type.
Public method Variant(Int32) Constructor for the Variant class. Constructs a variant with the specified value of the long integer type.
Public method Variant(String) Constructor for the Variant class. Constructs a variant with the specified string value.
Top
Properties
  Name Description
Public property Boolean  
Public property Char  
Public property Color  
Public property Double  
Public property Float  
Public property Int  
Public property Long  
Public property Short  
Public property String  
Public property Type  
Public property Uchar  
Public property Uint  
Public property Ulong  
Public property Ushort  
Top
Methods
  Name Description
Public method CopyFrom(Variant) Copies the contents of the specified object into this object.
Public method DeleteElem If the variant's type is VariantType.Table, deletes the element with the specified string key from the table. For other types, the method is invalid.
Public method ElemAt If the variant's type is kTable, gets the key and OdGiVariant value from the table using the specified index. For other types, the method is invalid.
Public method ElemCount If the variant's type is Table, returns the number of the table's elements. For other types, the method is invalid.
Public method Equals Checks objects for equality.
(Overrides DisposableWrapperEquals(Object))
Public method get_Elem(String) If the variant's type is Table, gets the Variant value from the table using the specified key. For other types, the method is invalid.
Public method get_Elem(String, Variant) If the variant's type is Table, gets the variant value from the table using the specified key. For other types, the method is invalid.
Public method set_Elem If the variant's type is Table, sets the variant value from the table using the specified key. For other types, the method is invalid. If a key is not found, a new table with the specified key is created.
Top
See Also

©  Bricsys NV. All rights reserved.