AssocArrayCommonParameters Class

This .NET class wraps the AcDbAssocArrayCommonParameters class. It provides an interface to control array parameters that are common to rectangular, path, and polar array parameters.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesAssocArrayParameters
          Teigha.DatabaseServicesAssocArrayCommonParameters
            Teigha.DatabaseServicesAssocArrayPathParameters
            Teigha.DatabaseServicesAssocArrayPolarParameters
            Teigha.DatabaseServicesAssocArrayRectangularParameters

Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public abstract class AssocArrayCommonParameters : AssocArrayParameters

The AssocArrayCommonParameters type exposes the following members.

Properties
  Name Description
Public property BaseNormal Property that represents normal vector to the base plane.
Public property BasePlane Property that represents the reference to the base plane geometry.
Public property BasePoint Property that represents the base point for the base plane.
Public property LevelCount Property that represents the level count of the array.
Public property LevelSpacing Property that represents the level spacing of the array.
Public property RowCount Property that represents the row count of the array.
Public property RowElevation Property that represents the row elevation of the array.
Public property RowSpacing Property that represents the row spacing of the array.
Top
Methods
  Name Description
Public method GetLevelCount Retrieves the level count of this array. If there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method executes.
Public method GetLevelSpacing Retrieves the level spacing of this array. If there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method executes.
Public method GetRowCount Retrieves the row count of this array. If there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method executes.
Public method GetRowElevation Retrieves the row elevation of this array. If there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method executes.
Public method GetRowSpacing Retrieves the row spacing of this array. If there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method executes.
Public method SetLevelCount Sets the level count for this array. If there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
Public method SetLevelSpacing Sets the level spacing for this array. If there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
Public method SetRowCount Sets the row count for this array. If there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
Public method SetRowElevation Sets the row elevation for this array. If there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
Public method SetRowSpacing Sets the row spacing for this array. If there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
Top
See Also

©  Bricsys NV. All rights reserved.