AssocArrayPolarParameters Class

This .NET class wraps the OdDbAssocArrayPolarParameters class.

It provides an interface for managing polar array parameters.

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesAssocArrayParameters
          Teigha.DatabaseServicesAssocArrayCommonParameters
            Teigha.DatabaseServicesAssocArrayPolarParameters

Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public class AssocArrayPolarParameters : AssocArrayCommonParameters

The AssocArrayPolarParameters type exposes the following members.

Constructors
  Name Description
Public method AssocArrayPolarParameters Default constructor for the AssocArrayPolarParameters class. Creates an object that wraps the corresponding C++ OdDbAssocArrayPolarParameters object with default parameters.
Public method AssocArrayPolarParameters(Double, Double, Double, Int32, Int32, Int32, Double) Constructor for the AssocArrayPolarParameters class. Creates an object with the specified spacing, count, elevation and angle parameters.
Top
Properties
  Name Description
Public property AngleBetweenItems  
Public property Direction  
Public property FillAngle  
Public property ItemCount  
Public property Radius  
Public property RotateItems  
Public property StartAngle  
Top
Methods
  Name Description
Public method GetAngleBetweenItems  
Public method GetFillAngle  
Public method GetItemCount Retrieves the item count of the polar array. If there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method executes.
Public method GetRadius Retrieves the radius of the polar array. If there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method executes.
Public method GetStartAngle Retrieves the start angle. If there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method executes.
Public method SetAngleBetweenItems Sets the angle between items in the polar array. If there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
Public method SetFillAngle Sets the angle between the first and last items in the polar array. If there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
Public method SetItemCount Sets the item count of the polar array. If there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
Public method SetRadius Sets the radius of the polar array. If there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
Public method SetStartAngle Sets the start angle of the polar array. If there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
Top
See Also

©  Bricsys NV. All rights reserved.